summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-09-12 15:54:40 +1200
committerKent Fredric <kentnl@gentoo.org>2020-09-12 15:55:35 +1200
commit056406a8393f938f09806b6500eae647321acd58 (patch)
treecaba1657fb2363f7b77ed8c8a459614ed480765e /dev-perl/Finance-Quote/Finance-Quote-1.490.0.ebuild
parentdev-perl/Text-Template: keyword ~arm64 (diff)
downloadgentoo-056406a8393f938f09806b6500eae647321acd58.tar.gz
gentoo-056406a8393f938f09806b6500eae647321acd58.tar.bz2
gentoo-056406a8393f938f09806b6500eae647321acd58.zip
dev-perl/Finance-Quote: Bump to version 1.490.0
- EAPI7 - Unconditionally strip author tests Upstream: - Alphavangage: - Add waiting mechansim to comply with use terms - Add several sock exchange supports and currency - Updated modules: Union, Deka, Indiamutual, ASX, Yahoojson, TSP, TSP, AEX, Fool - New modules: IEXTrading, MorningstarAU, MorningstarCH, IEXCloud - Yahoo: - Removed modules referring to removed Yahoo API - Fix "use if unintialized vlaue" returned by perl causing gnucash to fail when more than 15 quotes are requested - Workaround windows stftime not supporting "%T" Keywords: - due to new dependencies, various keywords are dropped to be restored later. - dev-perl/JSON-Parse -> alpha ppc ppc64 - dev-perl/String-Util -> alpha arm64 ppc ppc64 - dev-perl/Text-Template -> ppc64 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Finance-Quote/Finance-Quote-1.490.0.ebuild')
-rw-r--r--dev-perl/Finance-Quote/Finance-Quote-1.490.0.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/dev-perl/Finance-Quote/Finance-Quote-1.490.0.ebuild b/dev-perl/Finance-Quote/Finance-Quote-1.490.0.ebuild
new file mode 100644
index 000000000000..556276c0cac1
--- /dev/null
+++ b/dev-perl/Finance-Quote/Finance-Quote-1.490.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ECOCODE
+DIST_VERSION=1.49
+DIST_EXAMPLES=( "Examples/*" )
+inherit perl-module
+
+DESCRIPTION="Get stock and mutual fund quotes from various exchanges"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/CGI
+ virtual/perl-Carp
+ dev-perl/DateTime
+ dev-perl/DateTime-Format-Strptime
+ virtual/perl-Encode
+ virtual/perl-Exporter
+ virtual/perl-File-Temp
+ dev-perl/HTML-Parser
+ dev-perl/HTML-TableExtract
+ dev-perl/HTML-Tree
+ dev-perl/HTTP-Cookies
+ dev-perl/HTTP-Message
+ dev-perl/JSON
+ dev-perl/JSON-Parse
+ dev-perl/LWP-Protocol-https
+ dev-perl/libwww-perl
+ dev-perl/Mozilla-CA
+ virtual/perl-Scalar-List-Utils
+ dev-perl/String-Util
+ dev-perl/Text-Template
+ virtual/perl-Time-Piece
+ dev-perl/URI
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ virtual/perl-Test-Simple
+ )
+"
+PERL_RM_FILES=(
+ t/01-pod.t
+ t/02-pod-coverage.t
+ t/03-kwalitee.t
+ t/04-critic.t
+ t/author-pod-syntax.t
+ lib/GPATH
+ lib/GRTAGS
+ lib/GTAGS
+)
+
+src_test() {
+ if ! has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+ einfo "Disabling network tests without DIST_TEST_OVERRIDE=~network"
+ else
+ export ONLINE_TEST=1
+ fi
+ perl-module_src_test
+}
+
+mydoc=("Documentation/*")
+
+src_install() {
+ dodoc -r htdocs
+ perl-module_src_install
+}