summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-06-05 17:10:56 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-06-05 17:21:41 +0200
commit757c261d8767e69986f6ecac43d07bf136916ed5 (patch)
tree9463e2b46fed0a9601fe8656acc8cb6644623fde /dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.49.0.ebuild
parentdev-perl/Git-Wrapper: Version bump 0.048 (diff)
downloadgentoo-757c261d8767e69986f6ecac43d07bf136916ed5.tar.gz
gentoo-757c261d8767e69986f6ecac43d07bf136916ed5.tar.bz2
gentoo-757c261d8767e69986f6ecac43d07bf136916ed5.zip
dev-perl/Glib-Object-Introspection: Version bump 0.049
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.49.0.ebuild')
-rw-r--r--dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.49.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.49.0.ebuild b/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.49.0.ebuild
new file mode 100644
index 000000000000..5512348e7a2b
--- /dev/null
+++ b/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.49.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=XAOC
+DIST_VERSION=0.049
+inherit perl-module xdg-utils
+
+DESCRIPTION="Dynamically create Perl language bindings"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-perl/glib-perl-1.320.0
+ >=dev-libs/gobject-introspection-1.0
+ >=dev-libs/libffi-3.0.0:0=
+ >=dev-libs/glib-2.0.0
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ >=dev-perl/ExtUtils-Depends-0.300.0
+ >=dev-perl/ExtUtils-PkgConfig-1.0.0
+ ${RDEPEND}
+"
+
+pkg_setup() {
+ xdg_environment_reset # bug #599128
+}