summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-06-06 15:18:52 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-06-06 15:28:05 +0200
commitccfd5d056ec48f5cc3fbd13180caa51d2a7b027f (patch)
tree308789c0c0e3b6a192603e9e10bd36cc5cfb20a2 /dev-perl/Google-Ads-AdWords-Client/Google-Ads-AdWords-Client-5.8.2.ebuild
parentdev-python/humanize: add 3.7.1 (diff)
downloadgentoo-ccfd5d056ec48f5cc3fbd13180caa51d2a7b027f.tar.gz
gentoo-ccfd5d056ec48f5cc3fbd13180caa51d2a7b027f.tar.bz2
gentoo-ccfd5d056ec48f5cc3fbd13180caa51d2a7b027f.zip
dev-perl/Google-Ads-AdWords-Client: Version bump 5.8.2
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Google-Ads-AdWords-Client/Google-Ads-AdWords-Client-5.8.2.ebuild')
-rw-r--r--dev-perl/Google-Ads-AdWords-Client/Google-Ads-AdWords-Client-5.8.2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-perl/Google-Ads-AdWords-Client/Google-Ads-AdWords-Client-5.8.2.ebuild b/dev-perl/Google-Ads-AdWords-Client/Google-Ads-AdWords-Client-5.8.2.ebuild
new file mode 100644
index 000000000000..e12f6564ae26
--- /dev/null
+++ b/dev-perl/Google-Ads-AdWords-Client/Google-Ads-AdWords-Client-5.8.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DIST_AUTHOR=SUNDQUIST
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Google AdWords API Perl Client Library"
+HOMEPAGE="https://github.com/googleads/googleads-perl-lib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/Class-Load
+ dev-perl/Class-Std-Fast
+ dev-perl/Crypt-OpenSSL-RSA
+ dev-perl/Data-Uniqid
+ dev-perl/TimeDate
+ virtual/perl-Digest-SHA
+ dev-perl/File-HomeDir
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-Getopt-Long
+ dev-perl/HTTP-Server-Simple
+ dev-perl/IO-Socket-SSL
+ dev-perl/JSON-Parse
+ dev-perl/LWP-Protocol-https
+ dev-perl/libwww-perl
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Log-Log4perl
+ dev-perl/Math-Random-MT
+ >=dev-perl/SOAP-WSDL-2.00.10
+ dev-perl/Template-Toolkit
+ dev-perl/URI
+ dev-perl/XML-LibXML
+ dev-perl/XML-Simple
+ dev-perl/XML-XPath
+"
+
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.400.0
+ test? (
+ dev-perl/Config-Properties
+ virtual/perl-File-Temp
+ dev-perl/Test-Deep
+ dev-perl/Test-Exception
+ dev-perl/Test-MockObject
+ virtual/perl-Test-Simple
+ )
+"