summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-01 09:25:48 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-01 09:27:28 +1200
commit09ccf143bc9867cd618e6adde19b343ec4e52554 (patch)
tree47edb6e0ab0629bdd4c540a35374f8ee101e941b /dev-perl/Graph-Easy/Graph-Easy-0.760.0.ebuild
parentprofiles/package.mask: Mask cinnamon for removal (diff)
downloadgentoo-09ccf143bc9867cd618e6adde19b343ec4e52554.tar.gz
gentoo-09ccf143bc9867cd618e6adde19b343ec4e52554.tar.bz2
gentoo-09ccf143bc9867cd618e6adde19b343ec4e52554.zip
dev-perl/Graph-Easy: Add w/ version=0.760.0 re bug #718722
Closes: https://bugs.gentoo.org/718722 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Graph-Easy/Graph-Easy-0.760.0.ebuild')
-rw-r--r--dev-perl/Graph-Easy/Graph-Easy-0.760.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Graph-Easy/Graph-Easy-0.760.0.ebuild b/dev-perl/Graph-Easy/Graph-Easy-0.760.0.ebuild
new file mode 100644
index 000000000000..3edf63650f07
--- /dev/null
+++ b/dev-perl/Graph-Easy/Graph-Easy-0.760.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=0.76
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Convert or render graphs (as ASCII, HTML, SVG or via Graphviz)"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-Scalar-List-Utils-1.130.0
+"
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.360.0
+ test? (
+ dev-perl/Test-Differences
+ >=virtual/perl-Test-Simple-0.620.0
+ )
+"
+PERL_RM_FILES=(
+ "t/style-trailing-space.t"
+ "t/pod.t"
+ "t/pod_cov.t"
+)