summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarshall Brewer (Gentoo Key) <tomboy64@sina.cn>2016-04-18 16:36:12 +0200
committerIan Delaney <idella4@gentoo.org>2016-04-20 17:14:14 +0800
commitda47aed7754270b505b1d8240f829c6a29827def (patch)
tree3205b42b17941187b774d8a892a7d6e6094e4ac3 /dev-perl/Growl-GNTP/Growl-GNTP-0.210.0-r1.ebuild
parentwww-misc/monitorix: revbump to vn. 3.8.1-r1 (diff)
downloadgentoo-da47aed7754270b505b1d8240f829c6a29827def.tar.gz
gentoo-da47aed7754270b505b1d8240f829c6a29827def.tar.bz2
gentoo-da47aed7754270b505b1d8240f829c6a29827def.zip
dev-perl/Growl-GNTP: revbump, adjust dependencies
Package-Manager: portage-2.2.28 RepoMan-Options: --ignore-arches Closes: https://github.com/gentoo/gentoo/pull/1300 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-perl/Growl-GNTP/Growl-GNTP-0.210.0-r1.ebuild')
-rw-r--r--dev-perl/Growl-GNTP/Growl-GNTP-0.210.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Growl-GNTP/Growl-GNTP-0.210.0-r1.ebuild b/dev-perl/Growl-GNTP/Growl-GNTP-0.210.0-r1.ebuild
new file mode 100644
index 000000000000..5715539f9d9b
--- /dev/null
+++ b/dev-perl/Growl-GNTP/Growl-GNTP-0.210.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=MATTN
+DIST_VERSION=0.21
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="Perl implementation of GNTP Protocol (Client Part)"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ examples? ( virtual/perl-Encode )
+ >=dev-perl/Crypt-CBC-2.290.0
+ >=dev-perl/Data-UUID-0.149.0
+ >=virtual/perl-Digest-MD5-2.360.0
+ >=virtual/perl-Digest-SHA-5.450.0
+ virtual/perl-IO
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.35.0"
+
+src_test() {
+ my_test_control=${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}
+ if ! has 'network' ${my_test_control}; then
+ einfo "Network testing disabled"
+ perl_rm_files "t/01_simple.t"
+ fi
+ perl-module_src_test
+}