summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-04-23 22:52:24 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-04-23 22:52:34 +0200
commit99e9f122f37df36f4303679a589cef397e63332c (patch)
tree7a99131a7af75f161057fdba470e92fe3e3f7a9b /dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild
parentnet-misc/polly: Remove python@ from maintainers (diff)
downloadgentoo-99e9f122f37df36f4303679a589cef397e63332c.tar.gz
gentoo-99e9f122f37df36f4303679a589cef397e63332c.tar.bz2
gentoo-99e9f122f37df36f4303679a589cef397e63332c.zip
dev-perl/Gtk2-Notify: EAPI bump, disable broken test
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild')
-rw-r--r--dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild b/dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild
new file mode 100644
index 000000000000..bf2c56079921
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=FLORA
+DIST_VERSION=0.05
+inherit perl-module virtualx
+
+DESCRIPTION="A perl interface to the notification library"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/glib-perl
+ dev-perl/Gtk2
+ >=x11-libs/libnotify-0.7
+"
+DEPEND="${RDEPEND}
+ dev-perl/ExtUtils-Depends
+ dev-perl/ExtUtils-PkgConfig
+ test? ( dev-perl/Test-Exception )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.05-libnotify.patch )
+
+PERL_RM_FILES=( t/notification.t )
+# the test dies if no notification daemon is present...
+
+src_test() {
+ # bug 416729
+ virtx perl-module_src_test
+}