summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-06-12 23:06:35 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-06-12 23:46:20 +0200
commitf729076df34feb2ddf2f1e70631cb370c3736035 (patch)
tree8d5573afa13b7bb9f77e1987b8a7fcb0b8a8e249 /dev-perl/Gtk2-Unique/Gtk2-Unique-0.70.0.ebuild
parentapp-misc/tmux: Drop old (diff)
downloadgentoo-f729076df34feb2ddf2f1e70631cb370c3736035.tar.gz
gentoo-f729076df34feb2ddf2f1e70631cb370c3736035.tar.bz2
gentoo-f729076df34feb2ddf2f1e70631cb370c3736035.zip
dev-perl/Gtk2-Unique: Version bump 0.07
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Gtk2-Unique/Gtk2-Unique-0.70.0.ebuild')
-rw-r--r--dev-perl/Gtk2-Unique/Gtk2-Unique-0.70.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Gtk2-Unique/Gtk2-Unique-0.70.0.ebuild b/dev-perl/Gtk2-Unique/Gtk2-Unique-0.70.0.ebuild
new file mode 100644
index 000000000000..e118c73fbd09
--- /dev/null
+++ b/dev-perl/Gtk2-Unique/Gtk2-Unique-0.70.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=XAOC
+DIST_VERSION=0.07
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module virtualx
+
+DESCRIPTION="Perl binding for C libunique library"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libunique:1
+ dev-perl/Gtk2
+"
+DEPEND="${RDEPEND}
+"
+BDEPEND="${RDEPEND}
+ dev-perl/glib-perl
+ dev-perl/ExtUtils-Depends
+ dev-perl/ExtUtils-PkgConfig
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.05-implicit-pointer.patch )
+
+src_test() {
+ virtx perl-module_src_test
+}