summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Gtk2-Unique
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Gtk2-Unique')
-rw-r--r--dev-perl/Gtk2-Unique/Gtk2-Unique-0.50.0-r1.ebuild27
-rw-r--r--dev-perl/Gtk2-Unique/Manifest1
-rw-r--r--dev-perl/Gtk2-Unique/files/Gtk2-Unique-0.05-implicit-pointer.patch13
-rw-r--r--dev-perl/Gtk2-Unique/metadata.xml13
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-perl/Gtk2-Unique/Gtk2-Unique-0.50.0-r1.ebuild b/dev-perl/Gtk2-Unique/Gtk2-Unique-0.50.0-r1.ebuild
new file mode 100644
index 000000000000..b5a2029ea58d
--- /dev/null
+++ b/dev-perl/Gtk2-Unique/Gtk2-Unique-0.50.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=POTYL
+MODULE_VERSION=0.05
+inherit perl-module
+
+DESCRIPTION="Perl binding for C libunique library"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libunique:1
+ dev-perl/gtk2-perl
+"
+DEPEND="${RDEPEND}
+ dev-perl/glib-perl
+ dev-perl/ExtUtils-Depends
+ dev-perl/extutils-pkgconfig
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.05-implicit-pointer.patch )
diff --git a/dev-perl/Gtk2-Unique/Manifest b/dev-perl/Gtk2-Unique/Manifest
new file mode 100644
index 000000000000..9ad159b61877
--- /dev/null
+++ b/dev-perl/Gtk2-Unique/Manifest
@@ -0,0 +1 @@
+DIST Gtk2-Unique-0.05.tar.gz 11158 SHA256 ae8dfb0f6844ddaa2ce7b5b44553419490c8e83c24fd35c431406a58f6be0f4f SHA512 9ed700de45e6d7e5410ff4b4313869be9127b7933faf862f4f34f4330165dbda4b1d983efddedcd71487d0cdbf10982a7b76af7cf60339ae3359f57271177492 WHIRLPOOL 0e9fd1b0f2cd79ff24cfb435f89b0fdc9d39e536fff561b5d3950f60021369f9dddb5bce360db155b7cc8e7068a1a01e6b04e96b5082dd68a28c81aa6ecb08f6
diff --git a/dev-perl/Gtk2-Unique/files/Gtk2-Unique-0.05-implicit-pointer.patch b/dev-perl/Gtk2-Unique/files/Gtk2-Unique-0.05-implicit-pointer.patch
new file mode 100644
index 000000000000..1df58449b8b4
--- /dev/null
+++ b/dev-perl/Gtk2-Unique/files/Gtk2-Unique-0.05-implicit-pointer.patch
@@ -0,0 +1,13 @@
+Index: Gtk2-Unique-0.05/xs/UniqueApp.xs
+===================================================================
+--- Gtk2-Unique-0.05.orig/xs/UniqueApp.xs
++++ Gtk2-Unique-0.05/xs/UniqueApp.xs
+@@ -1,6 +1,8 @@
+ #include "unique-perl.h"
+ #include <gperl_marshal.h>
+
++G_CONST_RETURN gchar * unique_command_to_string (UniqueApp *app, gint command);
++
+ static void
+ perl_unique_app_marshall_message_received (
+ GClosure *closure,
diff --git a/dev-perl/Gtk2-Unique/metadata.xml b/dev-perl/Gtk2-Unique/metadata.xml
new file mode 100644
index 000000000000..daa6afc1ff76
--- /dev/null
+++ b/dev-perl/Gtk2-Unique/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>perl</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<upstream>
+<remote-id type="cpan">Gtk2-Unique</remote-id>
+<remote-id type="cpan-module">Gtk2::Unique</remote-id>
+</upstream>
+</pkgmetadata>