summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-02-20 15:34:29 +1300
committerKent Fredric <kentfredric@gmail.com>2016-02-20 20:47:54 +1300
commit2ffc09e8354d7584817ceeae4185b4f9dbb800a4 (patch)
tree6bdde78c3d1b658c69a27ee59c7981461272129b /dev-perl/HTML-FromText/HTML-FromText-2.70.0.ebuild
parentdev-perl/Getopt-Long-Descriptive: Bump to version 0.99.0 (diff)
downloadgentoo-2ffc09e8354d7584817ceeae4185b4f9dbb800a4.tar.gz
gentoo-2ffc09e8354d7584817ceeae4185b4f9dbb800a4.tar.bz2
gentoo-2ffc09e8354d7584817ceeae4185b4f9dbb800a4.zip
dev-perl/HTML-FromText: Bump to version 2.70.0
- use EAPI6 - Fix missing and surplus dependencies - Tests pass Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-perl/HTML-FromText/HTML-FromText-2.70.0.ebuild')
-rw-r--r--dev-perl/HTML-FromText/HTML-FromText-2.70.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/HTML-FromText/HTML-FromText-2.70.0.ebuild b/dev-perl/HTML-FromText/HTML-FromText-2.70.0.ebuild
new file mode 100644
index 000000000000..3a3a061bd81a
--- /dev/null
+++ b/dev-perl/HTML-FromText/HTML-FromText-2.70.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=2.07
+inherit perl-module
+
+DESCRIPTION="Convert plain text to HTML"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86"
+IUSE="test"
+
+# Email::Find::addrspec -> Email-Find 0.09
+# HTML::Entities -> HTML-Parser
+# Scalar::Util -> Scalar-List-Utils
+# test: File::Find -> perl
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Email-Find-0.90.0
+ >=virtual/perl-Exporter-5.58
+ >=dev-perl/HTML-Parser-1.260.0
+ >=virtual/perl-Scalar-List-Utils-1.120.0
+ >=virtual/perl-Text-Tabs+Wrap-98.112.800
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"