summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-24 20:47:31 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-24 21:31:19 +1300
commit0cb0b8ed8c6f116e26c1845920ec76ab15b9e0bc (patch)
tree2d95f770b52c6cf47e6d202c83dbb70fda6a500b /dev-perl/HTML-Strip/HTML-Strip-2.100.0.ebuild
parentdev-perl/HTML-Scrubber: Bump to version 0.170.0 (diff)
downloadgentoo-0cb0b8ed8c6f116e26c1845920ec76ab15b9e0bc.tar.gz
gentoo-0cb0b8ed8c6f116e26c1845920ec76ab15b9e0bc.tar.bz2
gentoo-0cb0b8ed8c6f116e26c1845920ec76ab15b9e0bc.zip
dev-perl/HTML-Strip: Bump to version 2.100.0
- EAPI6 Upstream: - Fix MSVC Compiles - Fix duplicate DESTROY in Strip warning Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/HTML-Strip/HTML-Strip-2.100.0.ebuild')
-rw-r--r--dev-perl/HTML-Strip/HTML-Strip-2.100.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/HTML-Strip/HTML-Strip-2.100.0.ebuild b/dev-perl/HTML-Strip/HTML-Strip-2.100.0.ebuild
new file mode 100644
index 000000000000..ddd3953339ae
--- /dev/null
+++ b/dev-perl/HTML-Strip/HTML-Strip-2.100.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=KILINRAX
+DIST_VERSION=2.10
+inherit perl-module
+
+DESCRIPTION="Extension for stripping HTML markup from text"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Exception
+ virtual/perl-Test-Simple
+ )
+"
+src_test() {
+ perl_rm_files t/400_kwalitee.t t/410_pod.t t/420_pod_coverage.t
+ perl-module_src_test
+}