summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-11-02 22:55:28 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-11-02 23:34:07 +0100
commitcd203c787631ea7c6d28b149359c8fb4d4761480 (patch)
tree7c6ad5da100fd65d8ab3edc91e8d3772c23af641 /dev-perl/HTTP-Request-AsCGI/HTTP-Request-AsCGI-1.200.0-r1.ebuild
parentdev-perl/HTTP-Negotiate: EAPI=8 bump (diff)
downloadgentoo-cd203c787631ea7c6d28b149359c8fb4d4761480.tar.gz
gentoo-cd203c787631ea7c6d28b149359c8fb4d4761480.tar.bz2
gentoo-cd203c787631ea7c6d28b149359c8fb4d4761480.zip
dev-perl/HTTP-Request-AsCGI: EAPI=8 bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/HTTP-Request-AsCGI/HTTP-Request-AsCGI-1.200.0-r1.ebuild')
-rw-r--r--dev-perl/HTTP-Request-AsCGI/HTTP-Request-AsCGI-1.200.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/HTTP-Request-AsCGI/HTTP-Request-AsCGI-1.200.0-r1.ebuild b/dev-perl/HTTP-Request-AsCGI/HTTP-Request-AsCGI-1.200.0-r1.ebuild
new file mode 100644
index 000000000000..f2a289880530
--- /dev/null
+++ b/dev-perl/HTTP-Request-AsCGI/HTTP-Request-AsCGI-1.200.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=FLORA
+DIST_VERSION=1.2
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Set up a CGI environment from an HTTP::Request"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 sparc x86"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Class-Accessor
+ >=dev-perl/HTTP-Message-1.530.0
+ virtual/perl-IO
+ dev-perl/URI
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+src_test() {
+ perl_rm_files "t/release-pod-syntax.t" "t/release-pod-coverage.t"
+ perl-module_src_test
+}