summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-02-04 23:38:40 +1300
committerKent Fredric <kentnl@gentoo.org>2020-02-04 23:40:09 +1300
commit30d6e9e94eb2a0b2a72778d9fcda422678eed08e (patch)
tree20208b4a5cf063aed24ff2aa866e1b747511dee4 /dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.4.1.ebuild
parentprofiles: Mask app-text/pybookreader for removal (diff)
downloadgentoo-30d6e9e94eb2a0b2a72778d9fcda422678eed08e.tar.gz
gentoo-30d6e9e94eb2a0b2a72778d9fcda422678eed08e.tar.bz2
gentoo-30d6e9e94eb2a0b2a72778d9fcda422678eed08e.zip
dev-perl/IO-Compress-Brotli: Add w/ version 0.4.1
Required as a dependency for bumping www-apps/webdavcgi to 1.1.2 Change suggested by Christian Affolter, but reworked from scratch to incorporate unbundling of brotli, and to employ proper versions, and EAPI7. Bug: https://bugs.gentoo.org/658470 Bug: https://github.com/gentoo/gentoo/pull/10826 Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.4.1.ebuild')
-rw-r--r--dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.4.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.4.1.ebuild b/dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.4.1.ebuild
new file mode 100644
index 000000000000..812152ba4882
--- /dev/null
+++ b/dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MGV
+DIST_VERSION=0.004001
+inherit perl-module
+
+DESCRIPTION="Read/write Brotli buffers/streams"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-perl/File-Slurper
+ virtual/perl-Getopt-Long
+ virtual/perl-Time-HiRes
+ app-arch/brotli:=
+"
+DEPEND="
+ app-arch/brotli:=
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-${DIST_VERSION}-unbundle.patch"
+)