summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-11-04 18:28:32 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-11-04 18:35:45 +0100
commit34ec146557a36e659d3fc94335db245c31005d5f (patch)
treec587684549096b811727fea241a973a2e06355cd /dev-perl/IO-Event/IO-Event-0.813.0-r2.ebuild
parentdev-perl/IO-CaptureOutput: Remove old (diff)
downloadgentoo-34ec146557a36e659d3fc94335db245c31005d5f.tar.gz
gentoo-34ec146557a36e659d3fc94335db245c31005d5f.tar.bz2
gentoo-34ec146557a36e659d3fc94335db245c31005d5f.zip
dev-perl/IO-Event: EAPI=8 bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/IO-Event/IO-Event-0.813.0-r2.ebuild')
-rw-r--r--dev-perl/IO-Event/IO-Event-0.813.0-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/IO-Event/IO-Event-0.813.0-r2.ebuild b/dev-perl/IO-Event/IO-Event-0.813.0-r2.ebuild
new file mode 100644
index 000000000000..99328e492e65
--- /dev/null
+++ b/dev-perl/IO-Event/IO-Event-0.813.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MUIR
+DIST_VERSION=0.813
+DIST_SECTION=modules
+inherit perl-module
+
+DESCRIPTION="Tied Filehandles for Nonblocking IO with Object Callbacks"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 sparc x86"
+
+RDEPEND="
+ dev-perl/AnyEvent
+ dev-perl/Event
+ dev-perl/List-MoreUtils
+ virtual/perl-Time-HiRes
+"
+BDEPEND="${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${P}-forked2.t.patch" )
+
+# Tests may fail under high load. This is less likely if they run sequentially.
+DIST_TEST=do