summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/IO-HTML
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/IO-HTML')
-rw-r--r--dev-perl/IO-HTML/IO-HTML-1.00.0.ebuild29
-rw-r--r--dev-perl/IO-HTML/IO-HTML-1.1.0.ebuild32
-rw-r--r--dev-perl/IO-HTML/Manifest2
-rw-r--r--dev-perl/IO-HTML/metadata.xml9
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-perl/IO-HTML/IO-HTML-1.00.0.ebuild b/dev-perl/IO-HTML/IO-HTML-1.00.0.ebuild
new file mode 100644
index 000000000000..8627a7a352db
--- /dev/null
+++ b/dev-perl/IO-HTML/IO-HTML-1.00.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=CJM
+MODULE_VERSION=1.00
+inherit perl-module
+
+DESCRIPTION="Open an HTML file with automatic charset detection"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Encode-2.100.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-File-Temp
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/IO-HTML/IO-HTML-1.1.0.ebuild b/dev-perl/IO-HTML/IO-HTML-1.1.0.ebuild
new file mode 100644
index 000000000000..e46036c2a7f7
--- /dev/null
+++ b/dev-perl/IO-HTML/IO-HTML-1.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=CJM
+MODULE_VERSION=1.001
+inherit perl-module
+
+DESCRIPTION="Open an HTML file with automatic charset detection"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=virtual/perl-Encode-2.100.0
+ >=virtual/perl-Exporter-5.570.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-File-Temp
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+# Scalar::Util
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/IO-HTML/Manifest b/dev-perl/IO-HTML/Manifest
new file mode 100644
index 000000000000..e2f38cb5b90d
--- /dev/null
+++ b/dev-perl/IO-HTML/Manifest
@@ -0,0 +1,2 @@
+DIST IO-HTML-1.00.tar.gz 18759 SHA256 04e29fd5f2535e35a9d478f2775471d79e2da6a3cf2bd33befb2dcd7811ad21a SHA512 26c718457d8bcf05f9f6b1e7f6da48557c0288cf0a63f7fcb5e6f022bc5c2f317c46056d7b07eedced252ff434a869b6b781a14344a1c60b3696acabd10dcc4b WHIRLPOOL 60014b779756a594b6c41dd41e4c538e0a2e604461e8e781b5ab5b7fdee0346db56a7b65be3fb54ef16ac366a49b7e4d932745a78e53c2eaaebdaa176dc9e0c3
+DIST IO-HTML-1.001.tar.gz 19375 SHA256 ea78d2d743794adc028bc9589538eb867174b4e165d7d8b5f63486e6b828e7e0 SHA512 fd3780c854e2e4003c80d2399987bbde2ebcc8f110915a74326660036d0860f79123f924c3200bcfa163363d74f53ca742bde973549e5a554e63648ed55dac52 WHIRLPOOL 1437e29aa020e8c612e29ad366392e36857b781ed017c3d329da552a4f3f8286737b14971098d70788e8cd694c8cae45cf412e08ab6e5f2787280d1f4752755d
diff --git a/dev-perl/IO-HTML/metadata.xml b/dev-perl/IO-HTML/metadata.xml
new file mode 100644
index 000000000000..6b3bc49a4eee
--- /dev/null
+++ b/dev-perl/IO-HTML/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">IO-HTML</remote-id>
+ <remote-id type="cpan-module">IO::HTML</remote-id>
+ </upstream>
+</pkgmetadata>