summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-26 11:33:29 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-26 11:34:06 +1300
commitb297e02ce5f9774bb7800c07b5f95a27de588c1b (patch)
treedb77d0c1c2f09f6ec743c2af869d826d88fb6812 /dev-perl/IO-Pager/IO-Pager-0.390.0.ebuild
parentgnome-base/dconf: bump to 0.26.1 (diff)
downloadgentoo-b297e02ce5f9774bb7800c07b5f95a27de588c1b.tar.gz
gentoo-b297e02ce5f9774bb7800c07b5f95a27de588c1b.tar.bz2
gentoo-b297e02ce5f9774bb7800c07b5f95a27de588c1b.zip
dev-perl/IO-Pager: Bump to version 0.390.0 re bug #616994
- Patched for '.' in @INC Upstream: - Packaging fixes - Partial '.' in @INC fixes - Fix uninitialized warnings Bug: https://bugs.gentoo.org/616994 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/IO-Pager/IO-Pager-0.390.0.ebuild')
-rw-r--r--dev-perl/IO-Pager/IO-Pager-0.390.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/IO-Pager/IO-Pager-0.390.0.ebuild b/dev-perl/IO-Pager/IO-Pager-0.390.0.ebuild
new file mode 100644
index 000000000000..d69218e446f7
--- /dev/null
+++ b/dev-perl/IO-Pager/IO-Pager-0.390.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_A_EXT=tgz
+DIST_AUTHOR=JPIERCE
+DIST_VERSION=0.39
+inherit perl-module
+
+DESCRIPTION="Select a pager, optionally pipe it output if destination is a TTY"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-File-Spec
+ dev-perl/File-Which
+ virtual/perl-IO
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Exporter
+ virtual/perl-Test-Simple
+ virtual/perl-File-Temp
+ )
+"
+PATCHES=( "${FILESDIR}/${P}-no-dot-inc.patch" )