summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-12-06 04:14:33 +1300
committerKent Fredric <kentnl@gentoo.org>2016-12-06 04:14:54 +1300
commit7f27cf108e25144d91fe9569a9c07ab3476238aa (patch)
tree44cc9756a1503a397a4700de4a44b8f747b0f0e5 /dev-perl/Inline-Python/Inline-Python-0.520.0.ebuild
parentnet-misc/hylafaxplus: Drop old (diff)
downloadgentoo-7f27cf108e25144d91fe9569a9c07ab3476238aa.tar.gz
gentoo-7f27cf108e25144d91fe9569a9c07ab3476238aa.tar.bz2
gentoo-7f27cf108e25144d91fe9569a9c07ab3476238aa.zip
dev-perl/Inline-Python: Bump to version 0.520.0
- EAPI6 - Parallel Tests Upstream: - Fix memory corruption after passing python dicts with non-string keys to Perl - Fix memory leaks passing python dicts with unicode keys to Perl Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/Inline-Python/Inline-Python-0.520.0.ebuild')
-rw-r--r--dev-perl/Inline-Python/Inline-Python-0.520.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Inline-Python/Inline-Python-0.520.0.ebuild b/dev-perl/Inline-Python/Inline-Python-0.520.0.ebuild
new file mode 100644
index 000000000000..465a895d6c23
--- /dev/null
+++ b/dev-perl/Inline-Python/Inline-Python-0.520.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+# Feel free to add more targets after testing.
+
+DIST_AUTHOR=NINE
+DIST_VERSION=0.52
+inherit python-single-r1 perl-module
+
+DESCRIPTION="Easy implementation of Python extensions"
+
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Data-Dumper
+ >=virtual/perl-Digest-MD5-2.500.0
+ >=dev-perl/Inline-0.460.0
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Proc-ProcessTable-0.530.0
+ virtual/perl-Test-Simple
+ dev-perl/Test-Deep
+ virtual/perl-Test
+ )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.460.0-insanepython.patch" )