summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-26 16:37:37 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-26 16:37:37 +1300
commitad76cf72f2135dfe4b83b55f23aad26a5f696552 (patch)
tree6574336534378e71f1712ad42a1c4cfea4cd9ade /dev-perl/Inline-Python
parentdev-perl/Image-Scale: Bump to version 0.130.0 (diff)
downloadgentoo-ad76cf72f2135dfe4b83b55f23aad26a5f696552.tar.gz
gentoo-ad76cf72f2135dfe4b83b55f23aad26a5f696552.tar.bz2
gentoo-ad76cf72f2135dfe4b83b55f23aad26a5f696552.zip
dev-perl/Inline-Python: Bump to version 0.560.0
Upstream: - Better support for serializing booleans with JSON - Support calling perl objects with overloaded code deref - Support overloaded stringification on perl objects - Pass python floats as floats to perl instead of strings - Fix floating point test failures Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Inline-Python')
-rw-r--r--dev-perl/Inline-Python/Inline-Python-0.560.0.ebuild38
-rw-r--r--dev-perl/Inline-Python/Manifest1
-rw-r--r--dev-perl/Inline-Python/metadata.xml1
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Inline-Python/Inline-Python-0.560.0.ebuild b/dev-perl/Inline-Python/Inline-Python-0.560.0.ebuild
new file mode 100644
index 000000000000..575cfddc122f
--- /dev/null
+++ b/dev-perl/Inline-Python/Inline-Python-0.560.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+# Feel free to add more targets after testing.
+
+DIST_AUTHOR=NINE
+DIST_VERSION=0.56
+inherit python-single-r1 perl-module
+
+DESCRIPTION="Easy implementation of Python extensions"
+
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Data-Dumper
+ >=virtual/perl-Digest-MD5-2.500.0
+ >=dev-perl/Inline-0.460.0
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Proc-ProcessTable-0.530.0
+ virtual/perl-Test-Simple
+ dev-perl/Test-Deep
+ dev-perl/Test-Number-Delta
+ virtual/perl-Test
+ )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.460.0-insanepython.patch" )
diff --git a/dev-perl/Inline-Python/Manifest b/dev-perl/Inline-Python/Manifest
index baa004fe0bd9..8a1abcbc72e2 100644
--- a/dev-perl/Inline-Python/Manifest
+++ b/dev-perl/Inline-Python/Manifest
@@ -1 +1,2 @@
DIST Inline-Python-0.52.tar.gz 57345 SHA256 9c946e1c9ac308d4431f07bbd3965a945850d69eab33aced6c81e674729e2ff4 SHA512 5b097740e149ae5a1a51d068f2732bff06daa03279ea3ad009b34fc72f0baccf0304989a3b9c3d9b8cadca1bb897693d48fb1a91ed3dc412c61463256a9bcaaa WHIRLPOOL ab2114881997791226b4e9005cc3d7daec553c21b0f595945abb941638b64ff85b31692c3c882edc523603c167e9dee16c8e75f5f84b8759a6f1d525b3f8755a
+DIST Inline-Python-0.56.tar.gz 58224 SHA256 ae2c437f367160ecfd6f8d6c6fe027ea6754feaa27648971c4a74e7fe934d95f SHA512 d5fffec8a377ec10c8b21ed9324e2de5a77d10304fc2a89196df89984e55869e3e4e0ef970f1aa4651068b8a6d834fa8eb18d70a052c646ddd98ef338f772e7d WHIRLPOOL f3ab40c765a0d6d6eeaef8c2ced24613fedf1e5bc8bccc6258dbab54f03d9f4edb63faabbcf5984d3dcaa02e3bec3ccf85209ab8c71e1e0306d78ef8f3974eb9
diff --git a/dev-perl/Inline-Python/metadata.xml b/dev-perl/Inline-Python/metadata.xml
index b1f32aff849d..7639860e78fb 100644
--- a/dev-perl/Inline-Python/metadata.xml
+++ b/dev-perl/Inline-Python/metadata.xml
@@ -8,6 +8,7 @@
<upstream>
<remote-id type="cpan">Inline-Python</remote-id>
<remote-id type="cpan-module">Inline::Python</remote-id>
+ <remote-id type="cpan-module">Inline::Python::Boolean</remote-id>
<remote-id type="cpan-module">Inline::Python::Function</remote-id>
<remote-id type="cpan-module">Inline::Python::Object</remote-id>
<remote-id type="cpan-module">Inline::Python::Object::Data</remote-id>