summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-26 19:15:13 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-26 19:15:13 +1300
commite789474126b7689a842763adb55e358e538866e7 (patch)
treeb2245e64259356c6cf5e5d94ea0ea5e7ac1a6632 /dev-perl/JSON-XS/JSON-XS-3.40.0.ebuild
parentdev-perl/JSON-Parse: Bump to version 0.550.0 (diff)
downloadgentoo-e789474126b7689a842763adb55e358e538866e7.tar.gz
gentoo-e789474126b7689a842763adb55e358e538866e7.tar.bz2
gentoo-e789474126b7689a842763adb55e358e538866e7.zip
dev-perl/JSON-XS: Bump to version 3.40.0
Upstream: - realloc algorithm now properly exponential - don't over-allocate output space in string encoding - croak if buffers get too large - add cbor-packed type to json_xs script - use YAML::XS in json_xs script Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/JSON-XS/JSON-XS-3.40.0.ebuild')
-rw-r--r--dev-perl/JSON-XS/JSON-XS-3.40.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/JSON-XS/JSON-XS-3.40.0.ebuild b/dev-perl/JSON-XS/JSON-XS-3.40.0.ebuild
new file mode 100644
index 000000000000..2e220e3310e8
--- /dev/null
+++ b/dev-perl/JSON-XS/JSON-XS-3.40.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MLEHMANN
+DIST_VERSION=3.04
+DIST_EXAMPLES=("eg/bench")
+inherit perl-module
+
+DESCRIPTION="JSON::XS - JSON serialising/deserialising, done correctly and fast"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Types-Serialiser
+ dev-perl/common-sense
+ !<dev-perl/JSON-2.900.0
+ !<dev-perl/JSON-Any-1.310.0
+"
+DEPEND="${RDEPEND}
+ dev-perl/Canary-Stability
+ >=virtual/perl-ExtUtils-MakeMaker-6.520.0
+ test? ( virtual/perl-Test-Harness )"