summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-06-22 23:37:43 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-06-22 23:38:15 +0200
commit79d43d904921e7ad765a6575b2ee656d9e3105b1 (patch)
treeab6f8d5c14244da7e7eee92604b8d3c3377c2b74 /dev-perl/LaTeX-Driver/LaTeX-Driver-1.2.0.ebuild
parentdev-python/adblock: add new package (diff)
downloadgentoo-79d43d904921e7ad765a6575b2ee656d9e3105b1.tar.gz
gentoo-79d43d904921e7ad765a6575b2ee656d9e3105b1.tar.bz2
gentoo-79d43d904921e7ad765a6575b2ee656d9e3105b1.zip
dev-perl/LaTeX-Driver: Version bump 1.2.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/LaTeX-Driver/LaTeX-Driver-1.2.0.ebuild')
-rw-r--r--dev-perl/LaTeX-Driver/LaTeX-Driver-1.2.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/LaTeX-Driver/LaTeX-Driver-1.2.0.ebuild b/dev-perl/LaTeX-Driver/LaTeX-Driver-1.2.0.ebuild
new file mode 100644
index 000000000000..f87c7e7142d3
--- /dev/null
+++ b/dev-perl/LaTeX-Driver/LaTeX-Driver-1.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=EHUELS
+inherit perl-module
+
+DESCRIPTION="Perl encapsulation of invoking the Latex programs"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ dev-perl/Capture-Tiny
+ dev-perl/Class-Accessor
+ dev-perl/Exception-Class
+ dev-perl/File-Slurp
+ virtual/perl-File-Spec
+ >=virtual/perl-File-Temp-0.230.0
+ dev-perl/File-pushd
+ virtual/perl-Getopt-Long
+ dev-perl/Log-Any
+ dev-perl/Readonly
+ virtual/perl-parent
+ virtual/latex-base
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Exception
+ app-text/texlive-core
+ dev-texlive/texlive-latexextra
+ )
+"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+
+ use test && perl_rm_files t/{90-kwalitee,91-pod,92-pod-coverage,93-perl-critic}.t
+
+ perl-module_src_prepare
+}