summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-30 02:57:25 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-30 04:07:02 +1300
commitc298c5e46845dfc9107fe2b62f3c47fdd2483665 (patch)
treeda1003f265ae23ca7270b98abbc63978bfd97341 /dev-perl/LaTeX-Table/LaTeX-Table-1.0.6-r1.ebuild
parentdev-perl/LWP-UserAgent-Cached: EAPI6, +remote-id's (diff)
downloadgentoo-c298c5e46845dfc9107fe2b62f3c47fdd2483665.tar.gz
gentoo-c298c5e46845dfc9107fe2b62f3c47fdd2483665.tar.bz2
gentoo-c298c5e46845dfc9107fe2b62f3c47fdd2483665.zip
dev-perl/LaTeX-Table: EAPI6, remote-id's
- EAPI6 - Add CPAN remote-ids - Enable USE=examples - Parallel Testing Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/LaTeX-Table/LaTeX-Table-1.0.6-r1.ebuild')
-rw-r--r--dev-perl/LaTeX-Table/LaTeX-Table-1.0.6-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/LaTeX-Table/LaTeX-Table-1.0.6-r1.ebuild b/dev-perl/LaTeX-Table/LaTeX-Table-1.0.6-r1.ebuild
new file mode 100644
index 000000000000..ff5eb1d74c75
--- /dev/null
+++ b/dev-perl/LaTeX-Table/LaTeX-Table-1.0.6-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=LIMAONE
+DIST_VERSION=v1.0.6
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Perl extension for the automatic generation of LaTeX tables"
+
+LICENSE="|| ( GPL-1+ Artistic )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Module-Pluggable
+ dev-perl/Moose
+ dev-perl/MooseX-FollowPBP
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Template-Toolkit
+ virtual/perl-version
+"
+DEPEND="${RDEPEND}
+ virtual/perl-File-Spec
+ dev-perl/Module-Build
+ test? ( dev-perl/Test-NoWarnings )
+"