summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2022-01-22 20:31:19 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2022-01-22 20:31:19 +0100
commit8334330c0a28f0dbcea4f9f3031b1fac68bce768 (patch)
treee59b881404b1b20428e33697ca30416ae9df6504 /dev-perl/Lab-Measurement
parentdev-perl/Lab-Measurement: stable 3.791 (diff)
downloadgentoo-8334330c0a28f0dbcea4f9f3031b1fac68bce768.tar.gz
gentoo-8334330c0a28f0dbcea4f9f3031b1fac68bce768.tar.bz2
gentoo-8334330c0a28f0dbcea4f9f3031b1fac68bce768.zip
dev-perl/Lab-Measurement: remove old
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Lab-Measurement')
-rw-r--r--dev-perl/Lab-Measurement/Lab-Measurement-3.780.ebuild149
-rw-r--r--dev-perl/Lab-Measurement/Manifest1
2 files changed, 0 insertions, 150 deletions
diff --git a/dev-perl/Lab-Measurement/Lab-Measurement-3.780.ebuild b/dev-perl/Lab-Measurement/Lab-Measurement-3.780.ebuild
deleted file mode 100644
index 142916460281..000000000000
--- a/dev-perl/Lab-Measurement/Lab-Measurement-3.780.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DIST_EXAMPLES=( "examples/*" )
-
-if [[ "${PV}" != "9999" ]]; then
- DIST_VERSION=${PV%.0}
- DIST_AUTHOR="AKHUETTEL"
- KEYWORDS="amd64 ~x86"
- inherit perl-module
-else
- EGIT_REPO_URI="https://github.com/lab-measurement/Lab-Measurement.git"
- EGIT_BRANCH="master"
- EGIT_CHECKOUT_DIR="${WORKDIR}/${PN}-git"
- inherit perl-module git-r3
-fi
-
-DESCRIPTION="Measurement control and automation with Perl"
-HOMEPAGE="https://www.labmeasurement.de"
-
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DZIL_PLUGINS=( Git PodWeaver AuthorsFromGit RPM )
-
-RDEPEND="
- virtual/perl-Carp
- dev-perl/Class-ISA
- >=dev-perl/Class-Method-Modifiers-2.110.0
- >=dev-perl/Clone-0.310.0
- virtual/perl-Data-Dumper
- virtual/perl-Encode
- >=dev-perl/Exception-Class-1.0.0
- virtual/perl-Exporter
- virtual/perl-File-Path
- virtual/perl-File-Spec
- virtual/perl-Getopt-Long
- dev-perl/Hook-LexWrap
- virtual/perl-IO
- >=dev-perl/IO-Socket-Timeout-0.320.0
- dev-perl/List-MoreUtils
- virtual/perl-Scalar-List-Utils
- virtual/perl-Math-Complex
- dev-perl/Math-Round
- >=virtual/perl-Module-Load-0.260.0
- >=dev-perl/Moose-2.121.300
- >=dev-perl/MooseX-Params-Validate-0.180.0
- dev-perl/MooseX-StrictConstructor
- >=dev-perl/PDL-2.7.0
- dev-perl/PDL-Graphics-Gnuplot
- >=dev-perl/Role-Tiny-1.3.4
- virtual/perl-Socket
- dev-perl/Statistics-Descriptive
- virtual/perl-Storable
- >=dev-perl/TermReadKey-2.300.0
- virtual/perl-Thread-Semaphore
- virtual/perl-Time-HiRes
- dev-perl/Time-Monotonic
- virtual/perl-Time-Piece
- >=dev-perl/Try-Tiny-0.220.0
- >=dev-perl/YAML-LibYAML-0.410.0
- virtual/perl-autodie
- >=dev-perl/namespace-autoclean-0.200.0
- virtual/perl-parent
- sci-visualization/gnuplot
- dev-perl/Lab-VXI11
- dev-perl/USB-TMC
-"
-DEPEND="
- ${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
- test? (
- dev-perl/File-Slurper
- virtual/perl-File-Temp
- dev-perl/Test-Fatal
- dev-perl/Test-File
- virtual/perl-Test-Simple
- dev-perl/Text-Diff
- dev-perl/aliased
- )
-"
-if [[ "${PV}" == "9999" ]]; then
- DEPEND="${DEPEND}
- dev-perl/Dist-Zilla"
- for dzp in "${DZIL_PLUGINS[@]}" ; do
- DEPEND="${DEPEND}
- dev-perl/Dist-Zilla-Plugin-${dzp}"
- done
-fi
-
-src_unpack() {
- if [[ "${PV}" == "9999" ]]; then
- git-r3_src_unpack
- mkdir -p "${S}" || die "Can't make ${S}"
- else
- default
- fi
-}
-
-dzil_to_distdir() {
- local dzil_root dest has_missing modname dzil_version
- dzil_root="$1"
- dest="$2"
-
- cd "${dzil_root}" || die "Can't enter git workdir '${dzil_root}'";
-
- dzil_version="$(dzil version)" || die "Error invoking 'dzil version'"
- einfo "Generating CPAN dist with ${dzil_version}"
-
- has_missing=""
-
- einfo "Checking dzil authordeps"
- while IFS= read -d $'\n' -r modname; do
- if [[ -z "${has_missing}" ]]; then
- has_missing=1
- eerror "'dzil authordeps' indicates missing build dependencies"
- eerror "These will prevent building, please report a bug"
- eerror "Missing:"
- fi
- eerror " ${modname}"
- done < <( dzil authordeps --missing --versions )
-
- [[ -z "${has_missing}" ]] || die "Satisfy all missing authordeps first"
-
- einfo "Checking dzil build deps"
- while IFS= read -d $'\n' -r modname; do
- if [[ -z "${has_missing}" ]]; then
- has_missing=1
- ewarn "'dzil listdeps' indicates missing build dependencies"
- ewarn "These may prevent building, please report a bug if they do"
- ewarn "Missing:"
- fi
- ewarn " ${modname}"
- done < <( dzil listdeps --missing --versions --author )
-
- einfo "Generating release"
- dzil build --notgz --in "${dest}" || die "Unable to build CPAN dist in '${dest}'"
-}
-
-src_prepare() {
- if [[ ${PV} == 9999 ]]; then
- dzil_to_distdir "${EGIT_CHECKOUT_DIR}" "${S}"
- fi
- cd "${S}" || die "Can't enter build dir"
- perl-module_src_prepare
-}
diff --git a/dev-perl/Lab-Measurement/Manifest b/dev-perl/Lab-Measurement/Manifest
index 49f3f0076f04..51c2699f9231 100644
--- a/dev-perl/Lab-Measurement/Manifest
+++ b/dev-perl/Lab-Measurement/Manifest
@@ -1,2 +1 @@
-DIST Lab-Measurement-3.780.tar.gz 641884 BLAKE2B b0d5117eeb022a7d58ffe975ba943a29689436911210eba63385df7e4536f850b5cc3a021e26ca60c9fc9cf19f359e2a648927ec5fc68ab2dea3a66fc1ac903c SHA512 260d670e7f67448c49fb82900fc0605978c6fcd39a6813c091a84977972f0965e25f14dd3568860cfe136f4628047e0720ea69710693513c5e567eeac10ddf97
DIST Lab-Measurement-3.791.tar.gz 662036 BLAKE2B f133d2590c91ef62a8c8234aa77e2c3eed2a43236d260e13d49a27fe89082be505f7aa9be79e1fbcd5c9d9c96068b1db50ad0a1377f84124bb47702c8801ba3c SHA512 c07fddf0b1c728fcb2aa17ada14edff32dcc3cb8fe7e23e9f770251562aef6c09343900e0104d8ef971b5366fdda27c212500993616be3b92422e0cba88873bb