summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-27 15:22:34 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-27 15:23:03 +1300
commit20e1e7e932c960d1afa4346b2b0f2fc311ca542e (patch)
tree13849d5082fe2e3a52cc1d2b1dc682659c730c0a /dev-perl/Lexical-SealRequireHints/Lexical-SealRequireHints-0.11.0.ebuild
parentx11-misc/fbpanel: Obsolete patch. (diff)
downloadgentoo-20e1e7e932c960d1afa4346b2b0f2fc311ca542e.tar.gz
gentoo-20e1e7e932c960d1afa4346b2b0f2fc311ca542e.tar.bz2
gentoo-20e1e7e932c960d1afa4346b2b0f2fc311ca542e.zip
dev-perl/Lexical-SealRequireHints: Bump to version 0.11.0 re bug #614968
Upstream: - Fixes tests for '.' in @INC - Stop shipping Makefile.PL - Use PERL_OP_PARENT compatible op munging Bug: https://bugs.gentoo.org/614968 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Lexical-SealRequireHints/Lexical-SealRequireHints-0.11.0.ebuild')
-rw-r--r--dev-perl/Lexical-SealRequireHints/Lexical-SealRequireHints-0.11.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Lexical-SealRequireHints/Lexical-SealRequireHints-0.11.0.ebuild b/dev-perl/Lexical-SealRequireHints/Lexical-SealRequireHints-0.11.0.ebuild
new file mode 100644
index 000000000000..f286829a7c47
--- /dev/null
+++ b/dev-perl/Lexical-SealRequireHints/Lexical-SealRequireHints-0.11.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ZEFRAM
+DIST_VERSION=0.011
+inherit perl-module
+
+DESCRIPTION="Prevent leakage of lexical hints"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="test"
+
+# Note: This module is a no-op at runtime since Perl 5.12
+# but is required for dependency resolution
+RDEPEND="
+ !<dev-perl/B-Hooks-OP-Check-0.190.0
+"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ >=virtual/perl-Test-Simple-0.410.0
+ )
+"
+src_test() {
+ perl_rm_files t/pod_{cvg{,_pp},syn}.t
+ perl-module_src_test
+}