summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-30 03:07:08 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-30 04:07:04 +1300
commitdd4affeb4d9280ce2a1283c272f5098ef65c39a3 (patch)
treea75902c3e7a4d049d3f11c7435f545c6564918af /dev-perl/Lingua-EN-NameCase/Lingua-EN-NameCase-1.190.0-r1.ebuild
parentdev-perl/Lchown: Enable tests (diff)
downloadgentoo-dd4affeb4d9280ce2a1283c272f5098ef65c39a3.tar.gz
gentoo-dd4affeb4d9280ce2a1283c272f5098ef65c39a3.tar.bz2
gentoo-dd4affeb4d9280ce2a1283c272f5098ef65c39a3.zip
dev-perl/Lingua-EN-NameCase: EAPI6, Remote-id's
- EAPI6 - Add CPAN remote ID's - Cleanup tests Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Lingua-EN-NameCase/Lingua-EN-NameCase-1.190.0-r1.ebuild')
-rw-r--r--dev-perl/Lingua-EN-NameCase/Lingua-EN-NameCase-1.190.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Lingua-EN-NameCase/Lingua-EN-NameCase-1.190.0-r1.ebuild b/dev-perl/Lingua-EN-NameCase/Lingua-EN-NameCase-1.190.0-r1.ebuild
new file mode 100644
index 000000000000..6eb9099708a6
--- /dev/null
+++ b/dev-perl/Lingua-EN-NameCase/Lingua-EN-NameCase-1.190.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=BARBIE
+DIST_VERSION=1.19
+inherit perl-module
+
+DESCRIPTION="Correctly case a person's name from UPERCASE or lowcase"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-IO
+ >=virtual/perl-Test-Simple-0.700.0
+ )
+"
+src_test() {
+ perl_rm_files t/9{0,1,4,5,6}*.t
+ perl-module_src_test
+}