summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-27 14:41:51 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-27 14:42:14 +1300
commit59b41fd1867fa2bef54f1683de702bbe94dfcfe4 (patch)
treed523685bd411500bf526745d8e79a258a42aef70 /dev-perl/List-UtilsBy
parentnet-vpn/tor: bump 0.3.1 branch to 0.3.1.8 (diff)
downloadgentoo-59b41fd1867fa2bef54f1683de702bbe94dfcfe4.tar.gz
gentoo-59b41fd1867fa2bef54f1683de702bbe94dfcfe4.tar.bz2
gentoo-59b41fd1867fa2bef54f1683de702bbe94dfcfe4.zip
dev-perl/List-UtilsBy: Fix test failures without '.' in @INC bug #615096
Closes: https://bugs.gentoo.org/615096 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/List-UtilsBy')
-rw-r--r--dev-perl/List-UtilsBy/List-UtilsBy-0.100.0.ebuild2
-rw-r--r--dev-perl/List-UtilsBy/files/List-UtilsBy-0.100.0-no-dot-inc.patch27
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-perl/List-UtilsBy/List-UtilsBy-0.100.0.ebuild b/dev-perl/List-UtilsBy/List-UtilsBy-0.100.0.ebuild
index 5026eba8331c..229589cd0784 100644
--- a/dev-perl/List-UtilsBy/List-UtilsBy-0.100.0.ebuild
+++ b/dev-perl/List-UtilsBy/List-UtilsBy-0.100.0.ebuild
@@ -17,7 +17,7 @@ DEPEND="
>=dev-perl/Module-Build-0.380.0
test? ( virtual/perl-Test-Simple )
"
-
+PATCHES=("${FILESDIR}/${P}-no-dot-inc.patch")
SRC_TEST=do
src_test() {
diff --git a/dev-perl/List-UtilsBy/files/List-UtilsBy-0.100.0-no-dot-inc.patch b/dev-perl/List-UtilsBy/files/List-UtilsBy-0.100.0-no-dot-inc.patch
new file mode 100644
index 000000000000..1ca063f24ef7
--- /dev/null
+++ b/dev-perl/List-UtilsBy/files/List-UtilsBy-0.100.0-no-dot-inc.patch
@@ -0,0 +1,27 @@
+From a7ce31efae156a93136b07136aead3e44b7d4b6c Mon Sep 17 00:00:00 2001
+From: Paul Evans <leonerd-cpan@leonerd.org.uk>
+Date: Mon, 27 Feb 2017 11:05:41 +0000
+Subject: Fix test failures without '.' in @INC
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=120418
+Bug: https://bugs.gentoo.org/615096
+---
+ t/11weighted_shuffle_by.t | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/t/11weighted_shuffle_by.t b/t/11weighted_shuffle_by.t
+index 68da739..0d41639 100644
+--- a/t/11weighted_shuffle_by.t
++++ b/t/11weighted_shuffle_by.t
+@@ -4,6 +4,8 @@ use strict;
+ use warnings;
+
+ use Test::More;
++
++use lib ".";
+ use t::Unrandom;
+
+ use List::UtilsBy qw( weighted_shuffle_by );
+--
+2.14.3
+