summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-28 17:47:26 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-29 12:54:22 +1300
commit565c9b4fba43fe040c22d9c25349bed2695905f9 (patch)
treec59d9a6e7f083493ea506430433232dce3542cd7 /dev-perl/Log-Dispatch/Log-Dispatch-2.670.0.ebuild
parentdev-perl/Log-Any: Bump to version 1.701.0 (diff)
downloadgentoo-565c9b4fba43fe040c22d9c25349bed2695905f9.tar.gz
gentoo-565c9b4fba43fe040c22d9c25349bed2695905f9.tar.bz2
gentoo-565c9b4fba43fe040c22d9c25349bed2695905f9.zip
dev-perl/Log-Dispatch: Bump to version 2.670.0
Upstream: - Improve level valdiation and canoniocalization - log_and_die and log_and_croak both work the same - failed chmods by ::File now show octal permissions - Fix ApacheLog output - Add lazy_open option to ::File output Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Log-Dispatch/Log-Dispatch-2.670.0.ebuild')
-rw-r--r--dev-perl/Log-Dispatch/Log-Dispatch-2.670.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-perl/Log-Dispatch/Log-Dispatch-2.670.0.ebuild b/dev-perl/Log-Dispatch/Log-Dispatch-2.670.0.ebuild
new file mode 100644
index 000000000000..2c3fac8b4ed4
--- /dev/null
+++ b/dev-perl/Log-Dispatch/Log-Dispatch-2.670.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=2.67
+inherit perl-module
+
+DESCRIPTION="Dispatches messages to one or more outputs"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-aix"
+IUSE="test"
+
+PERL_RM_FILES=(
+ "t/email-exit.t"
+)
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Devel-GlobalDestruction
+ >=dev-perl/Dist-CheckConflicts-0.20.0
+ virtual/perl-Encode
+ virtual/perl-Exporter
+ virtual/perl-IO
+ dev-perl/Module-Runtime
+ dev-perl/Params-ValidationCompiler
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/Specio-0.320.0
+ >=virtual/perl-Sys-Syslog-0.280.0
+ dev-perl/Try-Tiny
+ dev-perl/namespace-autoclean
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-Getopt-Long
+ dev-perl/IPC-Run3
+ dev-perl/Test-Fatal
+ dev-perl/Test-Needs
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"