summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/MIME-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/MIME-tools')
-rw-r--r--dev-perl/MIME-tools/MIME-tools-5.504.0.ebuild32
-rw-r--r--dev-perl/MIME-tools/MIME-tools-5.506.0.ebuild33
-rw-r--r--dev-perl/MIME-tools/Manifest2
-rw-r--r--dev-perl/MIME-tools/metadata.xml38
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-perl/MIME-tools/MIME-tools-5.504.0.ebuild b/dev-perl/MIME-tools/MIME-tools-5.504.0.ebuild
new file mode 100644
index 000000000000..4fdce22bc628
--- /dev/null
+++ b/dev-perl/MIME-tools/MIME-tools-5.504.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DSKOLL
+MODULE_VERSION=5.504
+inherit perl-module
+
+DESCRIPTION="A Perl module for parsing and creating MIME entities"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm64 hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+
+RDEPEND=">=virtual/perl-MIME-Base64-3.05
+ virtual/perl-libnet
+ dev-perl/URI
+ virtual/perl-Digest-MD5
+ dev-perl/libwww-perl
+ dev-perl/HTML-Tagset
+ dev-perl/HTML-Parser
+ dev-perl/MailTools
+ virtual/perl-File-Temp"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Deep
+ dev-perl/Test-Pod
+ )"
+
+SRC_TEST="do"
diff --git a/dev-perl/MIME-tools/MIME-tools-5.506.0.ebuild b/dev-perl/MIME-tools/MIME-tools-5.506.0.ebuild
new file mode 100644
index 000000000000..e04126356cdb
--- /dev/null
+++ b/dev-perl/MIME-tools/MIME-tools-5.506.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DSKOLL
+MODULE_VERSION=5.506
+inherit perl-module
+
+DESCRIPTION="A Perl module for parsing and creating MIME entities"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-File-Path-1
+ >=virtual/perl-File-Spec-0.600.0
+ >=virtual/perl-File-Temp-0.180.0
+ virtual/perl-IO
+ >=virtual/perl-MIME-Base64-2.200.0
+ dev-perl/MailTools
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ test? (
+ dev-perl/Test-Deep
+ dev-perl/Test-Pod
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/MIME-tools/Manifest b/dev-perl/MIME-tools/Manifest
new file mode 100644
index 000000000000..e904da75d4ff
--- /dev/null
+++ b/dev-perl/MIME-tools/Manifest
@@ -0,0 +1,2 @@
+DIST MIME-tools-5.504.tar.gz 404825 SHA256 0f5819eecd59bd46874f741dfc452a0a172e59a7ac6c422ce69e10593f7693d2 SHA512 0ff4d3991bc9e37edc39204051f7d9b9562a8afa23f768f0f653c554bf29c16ba315a043d63818c9e2ebc5f01a9f6961930dd8f4a1a501b5639bca36dde93c09 WHIRLPOOL 41059bd54a0537ff4e5cf76658248de9acaa603d514df88b26ee2fb2bd661fc854f02228a2c055ac107b06c77a35254a4bc97bcd1c659ddd3e840c437d11b1ec
+DIST MIME-tools-5.506.tar.gz 406565 SHA256 dbed9bf46830c4a1df9840a546824ee44d14902012870f0c34bc4f5cc86af812 SHA512 31cc1efb61100127bacfba435b7e500259bbb0e30206fb3fe125d2a86186e977eefecd7689e82bb4c8e76e8791c6c84719b276769c7e8fa6ab3b51cfa00b34c5 WHIRLPOOL fa6b24bbb33dbc658de87efcce5944e405c364ac262c60b022b770a5259816bb1027ff9dc82392784cb2183dc0fc0cb085f634de696f77bbde135df0498cbb21
diff --git a/dev-perl/MIME-tools/metadata.xml b/dev-perl/MIME-tools/metadata.xml
new file mode 100644
index 000000000000..ca4ac1b996cd
--- /dev/null
+++ b/dev-perl/MIME-tools/metadata.xml
@@ -0,0 +1,38 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">MIME-tools</remote-id>
+ <remote-id type="cpan-module">MIME::Body</remote-id>
+ <remote-id type="cpan-module">MIME::Body::File</remote-id>
+ <remote-id type="cpan-module">MIME::Body::InCore</remote-id>
+ <remote-id type="cpan-module">MIME::Body::Scalar</remote-id>
+ <remote-id type="cpan-module">MIME::Decoder</remote-id>
+ <remote-id type="cpan-module">MIME::Decoder::Base64</remote-id>
+ <remote-id type="cpan-module">MIME::Decoder::BinHex</remote-id>
+ <remote-id type="cpan-module">MIME::Decoder::Binary</remote-id>
+ <remote-id type="cpan-module">MIME::Decoder::Gzip64</remote-id>
+ <remote-id type="cpan-module">MIME::Decoder::NBit</remote-id>
+ <remote-id type="cpan-module">MIME::Decoder::QuotedPrint</remote-id>
+ <remote-id type="cpan-module">MIME::Decoder::UU</remote-id>
+ <remote-id type="cpan-module">MIME::Entity</remote-id>
+ <remote-id type="cpan-module">MIME::Field::ConTraEnc</remote-id>
+ <remote-id type="cpan-module">MIME::Field::ContDisp</remote-id>
+ <remote-id type="cpan-module">MIME::Field::ContType</remote-id>
+ <remote-id type="cpan-module">MIME::Field::ParamVal</remote-id>
+ <remote-id type="cpan-module">MIME::Head</remote-id>
+ <remote-id type="cpan-module">MIME::Parser</remote-id>
+ <remote-id type="cpan-module">MIME::Parser::FileInto</remote-id>
+ <remote-id type="cpan-module">MIME::Parser::FileUnder</remote-id>
+ <remote-id type="cpan-module">MIME::Parser::Filer</remote-id>
+ <remote-id type="cpan-module">MIME::Parser::Reader</remote-id>
+ <remote-id type="cpan-module">MIME::Parser::Results</remote-id>
+ <remote-id type="cpan-module">MIME::Tools</remote-id>
+ <remote-id type="cpan-module">MIME::WordDecoder</remote-id>
+ <remote-id type="cpan-module">MIME::WordDecoder::ISO_8859</remote-id>
+ <remote-id type="cpan-module">MIME::WordDecoder::US_ASCII</remote-id>
+ <remote-id type="cpan-module">MIME::WordDecoder::UTF_8</remote-id>
+ <remote-id type="cpan-module">MIME::Words</remote-id>
+ </upstream>
+</pkgmetadata>