summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Brewer <tomboy64@sina.cn>2016-04-01 02:32:44 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-03 23:23:43 +0200
commitdf50325fea10c361f80af2ab6f2f78039df36768 (patch)
tree80a3e821974f01f1c2144637e51ffc8196ff6fc4 /dev-perl/Math-Factor-XS/Math-Factor-XS-0.400.0.ebuild
parentdev-perl/Math-BigInt-Lite: initial ebuild, version 0.140.0 (diff)
downloadgentoo-df50325fea10c361f80af2ab6f2f78039df36768.tar.gz
gentoo-df50325fea10c361f80af2ab6f2f78039df36768.tar.bz2
gentoo-df50325fea10c361f80af2ab6f2f78039df36768.zip
dev-perl/Math-Factor-XS: initial ebuild, version 0.400.0
Package-Manager: portage-2.2.28 RepoMan-Options: --ignore-arches
Diffstat (limited to 'dev-perl/Math-Factor-XS/Math-Factor-XS-0.400.0.ebuild')
-rw-r--r--dev-perl/Math-Factor-XS/Math-Factor-XS-0.400.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Math-Factor-XS/Math-Factor-XS-0.400.0.ebuild b/dev-perl/Math-Factor-XS/Math-Factor-XS-0.400.0.ebuild
new file mode 100644
index 000000000000..0a26dfdbe6ce
--- /dev/null
+++ b/dev-perl/Math-Factor-XS/Math-Factor-XS-0.400.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR="KRYDE"
+DIST_VERSION=0.40
+inherit perl-module
+
+DESCRIPTION="Factorize numbers and calculate matching multiplications"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/boolean
+ dev-perl/List-MoreUtils
+ dev-perl/Params-Validate
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-XSLoader"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.400.0
+ virtual/perl-ExtUtils-CBuilder
+ test? ( virtual/perl-Test-Simple )"
+
+src_test() {
+ perl_rm_files "t/pod.t" "t/pod-coverage.t"
+ perl-module_src_test
+}