summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-02-22 14:44:59 +1300
committerKent Fredric <kentfredric@gmail.com>2016-02-27 21:39:56 +1300
commit98c84198c858853d00060fae42b4968cb1137a70 (patch)
treeabcbb7d9796fb32f89669d7204b80adb73d35583 /dev-perl/Math-GMP/Math-GMP-2.110.0.ebuild
parentdev-perl/Devel-CheckLib: Added to tree at 1.60.0 (diff)
downloadgentoo-98c84198c858853d00060fae42b4968cb1137a70.tar.gz
gentoo-98c84198c858853d00060fae42b4968cb1137a70.tar.bz2
gentoo-98c84198c858853d00060fae42b4968cb1137a70.zip
dev-perl/Math-GMP: Bump to version 2.110.0
- use EAPI6 - Had to drop keywords on alpha, hppa, mips and ppc due to dev-perl/Devel-CheckLib Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-perl/Math-GMP/Math-GMP-2.110.0.ebuild')
-rw-r--r--dev-perl/Math-GMP/Math-GMP-2.110.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Math-GMP/Math-GMP-2.110.0.ebuild b/dev-perl/Math-GMP/Math-GMP-2.110.0.ebuild
new file mode 100644
index 000000000000..a8fd894614c2
--- /dev/null
+++ b/dev-perl/Math-GMP/Math-GMP-2.110.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=2.11
+inherit perl-module
+
+DESCRIPTION="High speed arbitrary size integer math"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-AutoLoader
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ dev-libs/gmp:0
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Devel-CheckLib-0.900.0
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Test-Simple
+ )
+"