summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-02-22 23:58:48 +1300
committerKent Fredric <kentfredric@gmail.com>2016-02-27 21:39:56 +1300
commita16a988f24ed31a714120fe61d15a49e8a728031 (patch)
tree92119df3035ef33f73801db2ca6b01d0362c2f02 /dev-perl/MediaWiki-API/MediaWiki-API-0.410.0.ebuild
parentdev-perl/MLDBM: Bump to version 2.50.0 (diff)
downloadgentoo-a16a988f24ed31a714120fe61d15a49e8a728031.tar.gz
gentoo-a16a988f24ed31a714120fe61d15a49e8a728031.tar.bz2
gentoo-a16a988f24ed31a714120fe61d15a49e8a728031.zip
dev-perl/MediaWiki-API: Bump to version 0.410.0
- use EAPI6 - Fix wrong LICENSE - Clean up deps - Add network-test handling for people who set override="network" - Nuke spurious tests that can't help real problems Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-perl/MediaWiki-API/MediaWiki-API-0.410.0.ebuild')
-rw-r--r--dev-perl/MediaWiki-API/MediaWiki-API-0.410.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/MediaWiki-API/MediaWiki-API-0.410.0.ebuild b/dev-perl/MediaWiki-API/MediaWiki-API-0.410.0.ebuild
new file mode 100644
index 000000000000..68afa2ef73a5
--- /dev/null
+++ b/dev-perl/MediaWiki-API/MediaWiki-API-0.410.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=EXOBUZZ
+DIST_VERSION=0.41
+inherit perl-module
+
+DESCRIPTION="A OO interface to the Mediawiki API"
+LICENSE="GPL-3+"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/JSON
+ dev-perl/libwww-perl
+ virtual/perl-Carp
+ virtual/perl-Encode
+"
+DEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.980.0
+ )
+"
+src_test() {
+ local my_test_control
+ my_test_control=${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}
+ if has network ${my_test_control}; then
+ perl_rm_files "t/98-pod-coverage.t" "t/99-pod.t"
+ else
+ perl_rm_files "t/98-pod-coverage.t" "t/99-pod.t" "t/10-api.t"
+ fi
+ perl-module_src_test
+}