summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-21 14:10:01 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-21 16:36:08 +1300
commit14884a05c56ec63d6da099c76ccf12181e4c6606 (patch)
treea3c7003100bbe118cb6ce452bbb8fe617a2b247e /dev-perl/Mixin-Linewise/Mixin-Linewise-0.108.0.ebuild
parentdev-perl/PerlIO-utf8_strict: Add w/ version 0.6.0 (diff)
downloadgentoo-14884a05c56ec63d6da099c76ccf12181e4c6606.tar.gz
gentoo-14884a05c56ec63d6da099c76ccf12181e4c6606.tar.bz2
gentoo-14884a05c56ec63d6da099c76ccf12181e4c6606.zip
dev-perl/Mixin-Linewise: Add w/ version 0.108.0
Required for dev-perl/Config-INI, and subsequently, dev-perl/Dist-Zilla Previously maintained in ::perl-experimental since May 2009 by myself, with some contributions from Torsten Veller Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/Mixin-Linewise/Mixin-Linewise-0.108.0.ebuild')
-rw-r--r--dev-perl/Mixin-Linewise/Mixin-Linewise-0.108.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Mixin-Linewise/Mixin-Linewise-0.108.0.ebuild b/dev-perl/Mixin-Linewise/Mixin-Linewise-0.108.0.ebuild
new file mode 100644
index 000000000000..6852064aa84d
--- /dev/null
+++ b/dev-perl/Mixin-Linewise/Mixin-Linewise-0.108.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=6
+DIST_AUTHOR=RJBS
+DIST_VERSION=0.108
+inherit perl-module
+
+DESCRIPTION="write your linewise code for handles; this does the rest"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal"
+# r: IO::File -> IO
+# r: strict, warnings -> perl
+# t: lib, utf8 -> perl
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-IO
+ dev-perl/PerlIO-utf8_strict
+ dev-perl/Sub-Exporter
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ )
+ virtual/perl-Encode
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"