summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-perl/Modern-Perl
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-perl/Modern-Perl')
-rw-r--r--dev-perl/Modern-Perl/Modern-Perl-1.201.701.170.ebuild3
-rw-r--r--dev-perl/Modern-Perl/Modern-Perl-1.201.907.270.ebuild1
2 files changed, 3 insertions, 1 deletions
diff --git a/dev-perl/Modern-Perl/Modern-Perl-1.201.701.170.ebuild b/dev-perl/Modern-Perl/Modern-Perl-1.201.701.170.ebuild
index 5326010d172a..5ae5ff5eb05d 100644
--- a/dev-perl/Modern-Perl/Modern-Perl-1.201.701.170.ebuild
+++ b/dev-perl/Modern-Perl/Modern-Perl-1.201.701.170.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,6 +10,7 @@ DESCRIPTION="enable all of the features of Modern Perl with one import"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="virtual/perl-IO
>=virtual/perl-autodie-2.220.0"
DEPEND="${RDEPEND}
diff --git a/dev-perl/Modern-Perl/Modern-Perl-1.201.907.270.ebuild b/dev-perl/Modern-Perl/Modern-Perl-1.201.907.270.ebuild
index 48117be8367b..09acdd5d3f6b 100644
--- a/dev-perl/Modern-Perl/Modern-Perl-1.201.907.270.ebuild
+++ b/dev-perl/Modern-Perl/Modern-Perl-1.201.907.270.ebuild
@@ -10,6 +10,7 @@ DESCRIPTION="enable all of the features of Modern Perl with one import"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="virtual/perl-IO"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker