summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-02-23 02:21:20 +1300
committerKent Fredric <kentfredric@gmail.com>2016-02-27 21:39:56 +1300
commit1a8c03bcdc045638a31712695b48732486689d67 (patch)
treed3b967d0751ad9707daf34ea57e319af586482c0 /dev-perl/Module-Implementation/Module-Implementation-0.90.0.ebuild
parentdev-perl/Module-Build-XSUtil: Bump to version 0.160.0 (diff)
downloadgentoo-1a8c03bcdc045638a31712695b48732486689d67.tar.gz
gentoo-1a8c03bcdc045638a31712695b48732486689d67.tar.bz2
gentoo-1a8c03bcdc045638a31712695b48732486689d67.zip
dev-perl/Module-Implementation: Bump to version 0.90.0
- use EAPI6 - cleanup deps and tests Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-perl/Module-Implementation/Module-Implementation-0.90.0.ebuild')
-rw-r--r--dev-perl/Module-Implementation/Module-Implementation-0.90.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Module-Implementation/Module-Implementation-0.90.0.ebuild b/dev-perl/Module-Implementation/Module-Implementation-0.90.0.ebuild
new file mode 100644
index 000000000000..b7a3dabf1c63
--- /dev/null
+++ b/dev-perl/Module-Implementation/Module-Implementation-0.90.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=0.09
+inherit perl-module
+
+DESCRIPTION="Loads one of several alternate underlying implementations for a module"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Module-Runtime-0.12.0
+ dev-perl/Try-Tiny
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ dev-perl/Test-Requires
+ >=dev-perl/Test-Fatal-0.6.0
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+src_test() {
+ perl_rm_files "t/release-"* "t/author-"*
+ perl-module_src_test
+}