summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-03-07 07:15:14 +1300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-09 21:48:19 +0100
commitae3d6b2d9f3bf5322cafd573d7f8c01569b32336 (patch)
tree4f1edd1fbbc2a5e8b72c2e82cc72698a79913c22 /dev-perl/Module-Info
parentdev-perl/Net-SNMP: Fix packaging and incorrect dependencies (diff)
downloadgentoo-ae3d6b2d9f3bf5322cafd573d7f8c01569b32336.tar.gz
gentoo-ae3d6b2d9f3bf5322cafd573d7f8c01569b32336.tar.bz2
gentoo-ae3d6b2d9f3bf5322cafd573d7f8c01569b32336.zip
dev-perl/Module-Info: EAPI6ify + Remove unneeded test deps
- Use EAPI6 - Remove legacy assignment to MY_PN - Eliminate POD Tests ( Can only cause suffering at best ) - Remove POD Test deps Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-perl/Module-Info')
-rw-r--r--dev-perl/Module-Info/Module-Info-0.370.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Module-Info/Module-Info-0.370.0-r1.ebuild b/dev-perl/Module-Info/Module-Info-0.370.0-r1.ebuild
new file mode 100644
index 000000000000..388df7f5ce72
--- /dev/null
+++ b/dev-perl/Module-Info/Module-Info-0.370.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=NEILB
+DIST_VERSION=0.37
+inherit perl-module
+
+DESCRIPTION="Information about Perl modules"
+
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/B-Utils-0.270.0
+ virtual/perl-Carp
+ >=virtual/perl-File-Spec-0.800.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+src_test() {
+ perl_rm_files "t/zz_pod.t" "t/zy_pod_coverage.t"
+ perl-module_src_test
+}