summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-11-15 22:13:32 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-11-16 21:32:36 +0100
commit1a61ee6a1381bd9a1ba37c912f5e63f247294ed8 (patch)
treebc0706d5b2baf324ae960708c45c96989a4096da /dev-perl/Module-Runtime/Module-Runtime-0.16.0-r1.ebuild
parentdev-perl/Module-Path: EAPI=8 bump (diff)
downloadgentoo-1a61ee6a1381bd9a1ba37c912f5e63f247294ed8.tar.gz
gentoo-1a61ee6a1381bd9a1ba37c912f5e63f247294ed8.tar.bz2
gentoo-1a61ee6a1381bd9a1ba37c912f5e63f247294ed8.zip
dev-perl/Module-Runtime: EAPI=8 bump
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Module-Runtime/Module-Runtime-0.16.0-r1.ebuild')
-rw-r--r--dev-perl/Module-Runtime/Module-Runtime-0.16.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Module-Runtime/Module-Runtime-0.16.0-r1.ebuild b/dev-perl/Module-Runtime/Module-Runtime-0.16.0-r1.ebuild
new file mode 100644
index 000000000000..cb98cf7757fa
--- /dev/null
+++ b/dev-perl/Module-Runtime/Module-Runtime-0.16.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ZEFRAM
+DIST_VERSION=0.016
+inherit perl-module
+
+DESCRIPTION="Runtime module handling"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND=""
+BDEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+src_test() {
+ perl_rm_files t/pod_cvg.t t/pod_syn.t
+ perl-module_src_test
+}