summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-30 21:00:44 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-30 21:01:05 +1300
commitd033aa4bb8e1dc7270dc9c5648d7d949d0187b10 (patch)
treee0183a5d628fe9f71172145ffadd35c9987a1244 /dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild
parentnet-dns/c-ares: drop 1.12.0, bug #622278 (diff)
downloadgentoo-d033aa4bb8e1dc7270dc9c5648d7d949d0187b10.tar.gz
gentoo-d033aa4bb8e1dc7270dc9c5648d7d949d0187b10.tar.bz2
gentoo-d033aa4bb8e1dc7270dc9c5648d7d949d0187b10.zip
dev-perl/Module-Runtime: Bump to version 0.16.0 re bug #614338
Upstream: - Fix tests for Perl 5.27.5 w/ requiring loaded modules not triggering taint - Fix tests for '.' in @INC Bug: https://bugs.gentoo.org/614338 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild')
-rw-r--r--dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild b/dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild
new file mode 100644
index 000000000000..ca4242298ab3
--- /dev/null
+++ b/dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ZEFRAM
+DIST_VERSION=0.016
+inherit perl-module
+
+DESCRIPTION="Runtime module handling"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+SRC_TEST="do"
+
+src_test() {
+ perl_rm_files t/pod_cvg.t t/pod_syn.t
+ perl-module_src_test
+}