summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-13 12:44:18 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-13 12:44:18 +1200
commitcc885d37855f057d1bd8defe1d2916e1f824ca24 (patch)
tree6b50582f442e14eb3a758a19fea026822b7698ef /dev-perl/Mojolicious/Mojolicious-8.300.0.ebuild
parentdev-perl/Mojolicious: Bump to version 8.200.0 (diff)
downloadgentoo-cc885d37855f057d1bd8defe1d2916e1f824ca24.tar.gz
gentoo-cc885d37855f057d1bd8defe1d2916e1f824ca24.tar.bz2
gentoo-cc885d37855f057d1bd8defe1d2916e1f824ca24.zip
dev-perl/Mojolicious: Bump to version 8.300.0
Upstream: - *un*deprecate Mojo::Exception::verbose - add ENV var MOJO_EXCEPTION_VERBOSE - Built in templates now use the same stacktrace format as Mojo::Exception - Fix Mojo::Exception not correctly stringifying messages ending with "\n" - Mojo::Exception now appends file and line number to stringified exceptions that do not end with a "\n" - Update Cpanel::JSON::XS requirement to 4.09 for duplicate keys support - Add Mojo::Collection->{head,tail} - Mojo::File no longer allows undefined values in paths - Add experimental Mojo::Log->context - Add experimental Mojo::IOLoop::Subprocess `cleanup` event - Add `log` helper to Plugin::DefaultHelpers - Log messages generated by Mojolicious now include request_id's where possible - Add Mojo::File::curfile - Remove deprecated Mojo::Collection->slice - Move HTML entities from Mojo::Util to a seperate file - Event loop state determination in Reactor::EV now more consistent with Reactor::Poll - Add experimental `before_command` hook - Add experimental Mojo::Util::scope_guard - Mojo::Log->context no longer experimental - Default Mojolicious::Types content_type MIME type is now `application/octet-stream` - Add experimental async/await support with `Mojo::Base -async` - Add experimental Mojo::Promise->{all_settled,any} Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Mojolicious/Mojolicious-8.300.0.ebuild')
-rw-r--r--dev-perl/Mojolicious/Mojolicious-8.300.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Mojolicious/Mojolicious-8.300.0.ebuild b/dev-perl/Mojolicious/Mojolicious-8.300.0.ebuild
new file mode 100644
index 000000000000..d2daab52837d
--- /dev/null
+++ b/dev-perl/Mojolicious/Mojolicious-8.300.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SRI
+DIST_VERSION=8.30
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Real-time web framework"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="test minimal"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !minimal? (
+ >=dev-perl/EV-4.0.0
+ )
+ >=virtual/perl-IO-Socket-IP-0.370.0
+ >=virtual/perl-JSON-PP-2.271.30
+ >=virtual/perl-Scalar-List-Utils-1.410.0
+ >=virtual/perl-Time-Local-1.200.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+PERL_RM_FILES=(
+ t/pod.t
+ t/pod_coverage.t
+)