summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Monitoring-Plugin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Monitoring-Plugin')
-rw-r--r--dev-perl/Monitoring-Plugin/Manifest2
-rw-r--r--dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.380.0.ebuild23
-rw-r--r--dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.390.0.ebuild30
-rw-r--r--dev-perl/Monitoring-Plugin/metadata.xml20
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-perl/Monitoring-Plugin/Manifest b/dev-perl/Monitoring-Plugin/Manifest
new file mode 100644
index 000000000000..4645515adbc1
--- /dev/null
+++ b/dev-perl/Monitoring-Plugin/Manifest
@@ -0,0 +1,2 @@
+DIST Monitoring-Plugin-0.38.tar.gz 62426 SHA256 bdf035b4f72e8fc9f67a9ae09080377a30187f10e7e09db0bd6430fe3a5dae87 SHA512 8e682c3e9ca823ac4f568134c060a3ff99b40aa7ecebd4e9988aa97c0312be658afa269bce7a182d6e744ea0bc3cc28f6360bb723a4fe611d68e6c96209e6f6b WHIRLPOOL b6415684154821663ed5311d482c798ea12746e356aafca0009b29b3c4f49fd1afb5f88144061fcc3e8f960ced543dd5c310c8cf1f96121bbdc8057290c80962
+DIST Monitoring-Plugin-0.39.tar.gz 62733 SHA256 5ceeaf33bc6205b847b1645a3a24cb65d1b85e19691a6333fa221c240de20c0c SHA512 7bdba894cffc0839586e52f3667157cf578e94734ddc0ccd05899f631271e5b69e9cbfe4b2fb59f68b45e1d13afc82b095b65e249527f2c448a38b93e510a05c WHIRLPOOL 7edf6b1989eea956e75e3f9386db776611412eec5c58fd04302301b6b4cc6d285d7be28e7f586f9885f1acab8e31b60283b5937508fc49e00fb6423876691526
diff --git a/dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.380.0.ebuild b/dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.380.0.ebuild
new file mode 100644
index 000000000000..2b171ae3b54c
--- /dev/null
+++ b/dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.380.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR="NIERLEIN"
+MODULE_VERSION="0.38"
+
+inherit perl-module
+
+DESCRIPTION="Modules to streamline Nagios, Icinga, Shinken, etc. plugins"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+DEPEND="dev-perl/Class-Accessor
+ dev-perl/Config-Tiny
+ dev-perl/Math-Calc-Units
+ dev-perl/Params-Validate"
+
+SRC_TEST=do
diff --git a/dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.390.0.ebuild b/dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.390.0.ebuild
new file mode 100644
index 000000000000..e197470c6909
--- /dev/null
+++ b/dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.390.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=NIERLEIN
+MODULE_VERSION=0.39
+inherit perl-module
+
+DESCRIPTION="Modules to streamline Nagios, Icinga, Shinken, etc. plugins"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Class-Accessor
+ dev-perl/Config-Tiny
+ virtual/perl-File-Spec
+ dev-perl/Math-Calc-Units
+ dev-perl/Params-Validate
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ test? ( >=virtual/perl-Test-Simple-0.620.0 )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Monitoring-Plugin/metadata.xml b/dev-perl/Monitoring-Plugin/metadata.xml
new file mode 100644
index 000000000000..bfa913289d0c
--- /dev/null
+++ b/dev-perl/Monitoring-Plugin/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Monitoring-Plugin</remote-id>
+ <remote-id type="cpan-module">Monitoring::Plugin</remote-id>
+ <remote-id type="cpan-module">Monitoring::Plugin::Config</remote-id>
+ <remote-id type="cpan-module">Monitoring::Plugin::ExitResult</remote-id>
+ <remote-id type="cpan-module">Monitoring::Plugin::Functions</remote-id>
+ <remote-id type="cpan-module">Monitoring::Plugin::Getopt</remote-id>
+ <remote-id type="cpan-module">Monitoring::Plugin::Performance</remote-id>
+ <remote-id type="cpan-module">Monitoring::Plugin::Range</remote-id>
+ <remote-id type="cpan-module">Monitoring::Plugin::Threshold</remote-id>
+ </upstream>
+</pkgmetadata>