summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-12-05 09:34:46 +1300
committerKent Fredric <kentnl@gentoo.org>2016-12-05 09:39:24 +1300
commitccab1d8b91c29fc8b2497371ab06ff0f9a75eeb9 (patch)
treea5ff5eee0c2ae1f9f01cbb35b770d22714151d34 /dev-perl/Moo/Moo-2.2.5.ebuild
parentdev-perl/Role-Tiny: Bump to version 2.0.5 (diff)
downloadgentoo-ccab1d8b91c29fc8b2497371ab06ff0f9a75eeb9.tar.gz
gentoo-ccab1d8b91c29fc8b2497371ab06ff0f9a75eeb9.tar.bz2
gentoo-ccab1d8b91c29fc8b2497371ab06ff0f9a75eeb9.zip
dev-perl/Moo: Bump to version 2.2.5
- EAPI6 Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/Moo/Moo-2.2.5.ebuild')
-rw-r--r--dev-perl/Moo/Moo-2.2.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Moo/Moo-2.2.5.ebuild b/dev-perl/Moo/Moo-2.2.5.ebuild
new file mode 100644
index 000000000000..e81e98e0afdf
--- /dev/null
+++ b/dev-perl/Moo/Moo-2.2.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=HAARG
+DIST_VERSION=2.002005
+inherit perl-module
+
+DESCRIPTION="Minimalist Object Orientation (with Moose compatiblity)"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+# needs Scalar::Util
+RDEPEND="
+ >=dev-perl/Class-Method-Modifiers-1.100.0
+ >=dev-perl/Devel-GlobalDestruction-0.110.0
+ >=virtual/perl-Exporter-5.570.0
+ >=dev-perl/Module-Runtime-0.14.0
+ >=dev-perl/Role-Tiny-2.0.4
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Fatal-0.3.0
+ >=virtual/perl-Test-Simple-0.940.0
+ )
+"