summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-08 21:19:53 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-08 21:33:10 +0200
commite56face30f7efdf49beb8dcedda96453ae247ea9 (patch)
treedd8b78f7c41a885eedbef03ea6e0aa7156ec40f2 /dev-perl/Moo/Moo-2.5.4.ebuild
parentdev-perl/Role-Tiny: Version bump 2.002004 (diff)
downloadgentoo-e56face30f7efdf49beb8dcedda96453ae247ea9.tar.gz
gentoo-e56face30f7efdf49beb8dcedda96453ae247ea9.tar.bz2
gentoo-e56face30f7efdf49beb8dcedda96453ae247ea9.zip
dev-perl/Moo: Version bump 2.005004
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Moo/Moo-2.5.4.ebuild')
-rw-r--r--dev-perl/Moo/Moo-2.5.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Moo/Moo-2.5.4.ebuild b/dev-perl/Moo/Moo-2.5.4.ebuild
new file mode 100644
index 000000000000..9643e6087f85
--- /dev/null
+++ b/dev-perl/Moo/Moo-2.5.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=HAARG
+DIST_VERSION=2.005004
+inherit perl-module
+
+DESCRIPTION="Minimalist Object Orientation (with Moose compatiblity)"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Class-Method-Modifiers-1.100.0
+ >=virtual/perl-Exporter-5.570.0
+ >=dev-perl/Role-Tiny-2.2.3
+ >=virtual/perl-Scalar-List-Utils-1.0.0
+ >=dev-perl/Sub-Quote-2.6.6
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Fatal-0.3.0
+ >=virtual/perl-Test-Simple-0.940.0
+ )
+"