summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-02-27 14:50:06 +1300
committerKent Fredric <kentfredric@gmail.com>2016-02-27 21:39:56 +1300
commitabd0117c6d21ed20ab4598962dd5d445ce6818a5 (patch)
treeadf0dee1bac2b520c5461a9eaf371243a01451ae /dev-perl/MooX-HandlesVia/MooX-HandlesVia-0.1.8.ebuild
parentdev-perl/MogileFS-Utils: Bump to version 2.290.0 (diff)
downloadgentoo-abd0117c6d21ed20ab4598962dd5d445ce6818a5.tar.gz
gentoo-abd0117c6d21ed20ab4598962dd5d445ce6818a5.tar.bz2
gentoo-abd0117c6d21ed20ab4598962dd5d445ce6818a5.zip
dev-perl/MooX-HandlesVia: Bump to version 0.1.8
- use EAPI6 Upstream: - removed hidden dependency on strictures - avoids bug in inheriting from Non-Moo based classes Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-perl/MooX-HandlesVia/MooX-HandlesVia-0.1.8.ebuild')
-rw-r--r--dev-perl/MooX-HandlesVia/MooX-HandlesVia-0.1.8.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/MooX-HandlesVia/MooX-HandlesVia-0.1.8.ebuild b/dev-perl/MooX-HandlesVia/MooX-HandlesVia-0.1.8.ebuild
new file mode 100644
index 000000000000..6e4ee9a6160f
--- /dev/null
+++ b/dev-perl/MooX-HandlesVia/MooX-HandlesVia-0.1.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=MATTP
+DIST_VERSION=0.001008
+inherit perl-module
+
+DESCRIPTION="NativeTrait-like behavior for Moo"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Class-Method-Modifiers
+ >=dev-perl/Data-Perl-0.2.6
+ dev-perl/Module-Runtime
+ >=dev-perl/Moo-1.3.0
+ dev-perl/Role-Tiny
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/MooX-Types-MooseLike-0.230.0
+ dev-perl/Test-Exception
+ dev-perl/Test-Fatal
+ virtual/perl-Test-Simple
+ )
+"