summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-11-19 21:35:52 +1300
committerKent Fredric <kentnl@gentoo.org>2017-11-19 21:35:52 +1300
commit55c9cac768796d1b3ff147172cebfa1ec05b75e0 (patch)
tree76b0a1da0f576eb6de5b3cac151072fec67fc64f /dev-perl/MooseX-Getopt/MooseX-Getopt-0.710.0.ebuild
parentdev-perl/MooseX-ClassAttribute: Bump to version 0.290.0 (diff)
downloadgentoo-55c9cac768796d1b3ff147172cebfa1ec05b75e0.tar.gz
gentoo-55c9cac768796d1b3ff147172cebfa1ec05b75e0.tar.bz2
gentoo-55c9cac768796d1b3ff147172cebfa1ec05b75e0.zip
dev-perl/MooseX-Getopt: Bump to version 0.710.0
Upstream: - private attributes with leading "_" with public init_arg now work - undefined init args no longer cause warnings and exceptions and are instead ignored - init_arg setting now respected when retrieving CLI options Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-perl/MooseX-Getopt/MooseX-Getopt-0.710.0.ebuild')
-rw-r--r--dev-perl/MooseX-Getopt/MooseX-Getopt-0.710.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/MooseX-Getopt/MooseX-Getopt-0.710.0.ebuild b/dev-perl/MooseX-Getopt/MooseX-Getopt-0.710.0.ebuild
new file mode 100644
index 000000000000..45e519cc0472
--- /dev/null
+++ b/dev-perl/MooseX-Getopt/MooseX-Getopt-0.710.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.71
+inherit perl-module
+
+DESCRIPTION="A Moose role for processing command line options"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=virtual/perl-Getopt-Long-2.370.0
+ >=dev-perl/Getopt-Long-Descriptive-0.88.0
+ >=dev-perl/Moose-0.560.0
+ >=dev-perl/MooseX-Role-Parameterized-1.10.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Try-Tiny
+ dev-perl/namespace-autoclean
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.34.0
+ test? (
+ virtual/perl-File-Spec
+ dev-perl/Module-Runtime
+ virtual/perl-Module-Metadata
+ >=dev-perl/Path-Tiny-0.9.0
+ dev-perl/Test-Deep
+ >=dev-perl/Test-Fatal-0.3.0
+ virtual/perl-Test-Simple
+ dev-perl/Test-Requires
+ dev-perl/Test-Trap
+ >=dev-perl/Test-Warnings-0.9.0
+ virtual/perl-if
+ )
+"