summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2019-07-16 12:13:28 +1200
committerKent Fredric <kentnl@gentoo.org>2019-07-16 12:14:13 +1200
commitb001a6f80c0999e3c7317d6777daf4876697e218 (patch)
tree39d290e2e46adb48f753dff80fc8a38c5ec75ac5 /dev-perl/MooseX-Getopt/MooseX-Getopt-0.740.0.ebuild
parentdev-perl/ExtUtils-Config: Fix typo in bad-test removal (diff)
downloadgentoo-b001a6f80c0999e3c7317d6777daf4876697e218.tar.gz
gentoo-b001a6f80c0999e3c7317d6777daf4876697e218.tar.bz2
gentoo-b001a6f80c0999e3c7317d6777daf4876697e218.zip
dev-perl/MooseX-Getopt: Bump to version 0.740.0 re bug #675719
Upstream: - Fix tests broken by Getopt::Long::Descriptive 0.103.0 - move exit() call to a higher scope to allow 'after' method-modifiers on 'print_usage_text' - Fix 'init_arg' when used in combination with an underscored attribute read from a configuration file. Bug: https://bugs.gentoo.org/675718 Bug: https://rt.cpan.org/Public/Bug/Display.html?id=125992 Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/MooseX-Getopt/MooseX-Getopt-0.740.0.ebuild')
-rw-r--r--dev-perl/MooseX-Getopt/MooseX-Getopt-0.740.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/MooseX-Getopt/MooseX-Getopt-0.740.0.ebuild b/dev-perl/MooseX-Getopt/MooseX-Getopt-0.740.0.ebuild
new file mode 100644
index 000000000000..ed41d8100190
--- /dev/null
+++ b/dev-perl/MooseX-Getopt/MooseX-Getopt-0.740.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.74
+inherit perl-module
+
+DESCRIPTION="A Moose role for processing command line options"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=virtual/perl-Getopt-Long-2.370.0
+ >=dev-perl/Getopt-Long-Descriptive-0.88.0
+ >=dev-perl/Moose-0.560.0
+ >=dev-perl/MooseX-Role-Parameterized-1.10.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Try-Tiny
+ dev-perl/namespace-autoclean
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Module-Build-Tiny-0.34.0
+ test? (
+ virtual/perl-File-Spec
+ dev-perl/Module-Runtime
+ virtual/perl-Module-Metadata
+ >=dev-perl/Path-Tiny-0.9.0
+ dev-perl/Test-Deep
+ >=dev-perl/Test-Fatal-0.3.0
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Needs
+ dev-perl/Test-Trap
+ >=dev-perl/Test-Warnings-0.9.0
+ virtual/perl-if
+ )
+"