summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-08 21:32:19 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-08 21:33:20 +0200
commit58d51eb149ef3e28e4f2a46e946cb1de76dffc4f (patch)
tree1b1b905722bd9b6d61eaad24040ce9f6185178d3 /dev-perl/MooseX-Getopt/MooseX-Getopt-0.750.0.ebuild
parentdev-perl/MooseX-Aliases: EAPI=8 bump (diff)
downloadgentoo-58d51eb149ef3e28e4f2a46e946cb1de76dffc4f.tar.gz
gentoo-58d51eb149ef3e28e4f2a46e946cb1de76dffc4f.tar.bz2
gentoo-58d51eb149ef3e28e4f2a46e946cb1de76dffc4f.zip
dev-perl/MooseX-Getopt: Version bump 0.75
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/MooseX-Getopt/MooseX-Getopt-0.750.0.ebuild')
-rw-r--r--dev-perl/MooseX-Getopt/MooseX-Getopt-0.750.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/MooseX-Getopt/MooseX-Getopt-0.750.0.ebuild b/dev-perl/MooseX-Getopt/MooseX-Getopt-0.750.0.ebuild
new file mode 100644
index 000000000000..bedffda369b2
--- /dev/null
+++ b/dev-perl/MooseX-Getopt/MooseX-Getopt-0.750.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.75
+inherit perl-module
+
+DESCRIPTION="A Moose role for processing command line options"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=virtual/perl-Getopt-Long-2.370.0
+ >=dev-perl/Getopt-Long-Descriptive-0.88.0
+ >=dev-perl/Moose-0.560.0
+ >=dev-perl/MooseX-Role-Parameterized-1.10.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Try-Tiny
+ dev-perl/namespace-autoclean
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Module-Build-Tiny-0.34.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Module-Metadata
+ dev-perl/Module-Runtime
+ >=dev-perl/Path-Tiny-0.9.0
+ dev-perl/Test-Deep
+ >=dev-perl/Test-Fatal-0.3.0
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Needs
+ dev-perl/Test-Trap
+ >=dev-perl/Test-Warnings-0.9.0
+ virtual/perl-if
+ )
+"