summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-09 22:44:19 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-09 22:44:19 +0200
commitdd90f5e630f9e2765cdccd2a7885830de2a37e4c (patch)
tree9626614a96aa12c0a8c29d1179bcfeb44355b5ca /dev-perl/Mouse/Mouse-2.5.10.ebuild
parentdev-perl/MooX-StrictConstructor: Version bump 0.011 (diff)
downloadgentoo-dd90f5e630f9e2765cdccd2a7885830de2a37e4c.tar.gz
gentoo-dd90f5e630f9e2765cdccd2a7885830de2a37e4c.tar.bz2
gentoo-dd90f5e630f9e2765cdccd2a7885830de2a37e4c.zip
dev-perl/Mouse: Versio bump v2.5.10
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Mouse/Mouse-2.5.10.ebuild')
-rw-r--r--dev-perl/Mouse/Mouse-2.5.10.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/Mouse/Mouse-2.5.10.ebuild b/dev-perl/Mouse/Mouse-2.5.10.ebuild
new file mode 100644
index 000000000000..49b987e4c821
--- /dev/null
+++ b/dev-perl/Mouse/Mouse-2.5.10.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SKAJI
+DIST_VERSION=v${PV}
+DIST_EXAMPLES=("example/*" "benchmarks")
+inherit perl-module
+
+DESCRIPTION="Moose minus the antlers"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64"
+
+RDEPEND="
+ >=virtual/perl-Scalar-List-Utils-1.140.0
+ >=virtual/perl-XSLoader-0.20.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-Devel-PPPort-3.420.0
+ >=virtual/perl-ExtUtils-ParseXS-3.220.0
+ >=dev-perl/Module-Build-0.400.500
+ >=dev-perl/Module-Build-XSUtil-0.190.0
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Fatal
+ dev-perl/Test-LeakTrace
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Output
+ dev-perl/Test-Requires
+ dev-perl/Try-Tiny
+ )
+"
+
+src_configure() {
+ unset LD
+ [[ -n "${CCLD}" ]] && export LD="${CCLD}"
+ # we have to do this outside src_compile
+ # as the stupid thing recompiles in src_install
+ myconf=(
+ --config "optimize=${CFLAGS}"
+ )
+ perl-module_src_configure
+}