summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-04 14:44:53 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-04 14:45:01 +1300
commit6ee6a62daf4dc130bbca9a1bf7646874fb1a9b48 (patch)
tree27bd081fb07bf85c665998c3819c94791c017365 /dev-perl/Net-DNS/Net-DNS-1.130.0.ebuild
parentdev-perl/Net-LibIDN2: Add w/ version 1.0.0 (diff)
downloadgentoo-6ee6a62daf4dc130bbca9a1bf7646874fb1a9b48.tar.gz
gentoo-6ee6a62daf4dc130bbca9a1bf7646874fb1a9b48.tar.bz2
gentoo-6ee6a62daf4dc130bbca9a1bf7646874fb1a9b48.zip
dev-perl/Net-DNS: Bump to version 1.130.0
- Improve support for elective network testing Upstream: - Send UDP queries with packetsize=512 - Extract default resolver from OS/390 MVS datasets - Fix persistent UDP reporting false timeouts - Fix TCP Retry stall due to old IO::Socket::IP - Implement RFC8078 Erratum 5049 - Support for querying domain names containing non-ASCII characters via libidn2 Keywords: - New deps, dropped: alpha, prefix, arm, hppa, ia64, m68k, mips, ppc*, s390, sh, sparc Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Net-DNS/Net-DNS-1.130.0.ebuild')
-rw-r--r--dev-perl/Net-DNS/Net-DNS-1.130.0.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-perl/Net-DNS/Net-DNS-1.130.0.ebuild b/dev-perl/Net-DNS/Net-DNS-1.130.0.ebuild
new file mode 100644
index 000000000000..33f8be047be1
--- /dev/null
+++ b/dev-perl/Net-DNS/Net-DNS-1.130.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=NLNETLABS
+DIST_VERSION=1.13
+DIST_EXAMPLES=( "contrib" "demo" )
+inherit toolchain-funcs perl-module
+
+DESCRIPTION="Perl Interface to the Domain Name System"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ipv6 test minimal"
+
+PDEPEND="!minimal? ( >=dev-perl/Net-DNS-SEC-1.10.0 )"
+RDEPEND="
+ >=dev-perl/Digest-HMAC-1.30.0
+ >=virtual/perl-Digest-MD5-2.130.0
+ >=virtual/perl-Digest-SHA-5.230.0
+ >=virtual/perl-File-Spec-0.860.0
+ >=virtual/perl-MIME-Base64-2.110.0
+ >=virtual/perl-Time-Local-1.190.0
+ ipv6? (
+ >=virtual/perl-IO-Socket-IP-0.380.0
+ )
+ !minimal? (
+ >=dev-perl/Digest-BubbleBabble-0.10.0
+ >=dev-perl/Net-LibIDN-0.120.0
+ >=dev-perl/Net-LibIDN2-1.0.0
+ >=virtual/perl-Scalar-List-Utils-1.250.0
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.520.0
+ )
+"
+
+src_prepare() {
+ perl-module_src_prepare
+ mydoc="TODO"
+ # --IPv6-tests requires that you have external IPv6 connectivity
+ # as it connects to 2001:7b8:206:1:0:1234:be21:e31e
+ if ! use test || ! has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+ myconf="${myconf} --no-online-tests --no-IPv6-tests"
+ fi
+}
+
+src_compile() {
+ emake FULL_AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}
+src_test() {
+ perl_rm_files t/00-pod.t
+ if ! has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+ elog "Network tests disabled without to DIST_TEST_OVERIDE=~network"
+ fi
+ perl-module_src_test
+}