summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-15 17:37:25 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-15 17:43:04 +0200
commitb7ae960d3b542786e84b4b35c3a96b88d731a633 (patch)
tree33a401093b74473087e26055694918719a762b3f /dev-perl/Net-IRC/Net-IRC-0.790.0-r2.ebuild
parentdev-perl/Net-IPv4Addr: EAPI=8 bump (diff)
downloadgentoo-b7ae960d3b542786e84b4b35c3a96b88d731a633.tar.gz
gentoo-b7ae960d3b542786e84b4b35c3a96b88d731a633.tar.bz2
gentoo-b7ae960d3b542786e84b4b35c3a96b88d731a633.zip
dev-perl/Net-IRC: EAPI=8 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Net-IRC/Net-IRC-0.790.0-r2.ebuild')
-rw-r--r--dev-perl/Net-IRC/Net-IRC-0.790.0-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Net-IRC/Net-IRC-0.790.0-r2.ebuild b/dev-perl/Net-IRC/Net-IRC-0.790.0-r2.ebuild
new file mode 100644
index 000000000000..a9704cf07f6d
--- /dev/null
+++ b/dev-perl/Net-IRC/Net-IRC-0.790.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=APEIRON
+DIST_VERSION=0.79
+inherit perl-module
+
+DESCRIPTION="Perl IRC module"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="amd64 ~arm ~arm64 ~mips ppc ~ppc64 x86"
+
+mydoc="TODO"
+
+src_prepare() {
+ # Remove the stdin and warning input required re deprecated.
+ sed -i \
+ -e '/or die $warning/d' \
+ -e '/my $acceptance/,/$acceptance eq $ok/d' \
+ "${S}"/Makefile.PL || die "sed failed"
+ perl-module_src_prepare
+}