summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-15 20:10:04 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-16 23:52:56 +1300
commitd1614f05077ba25d4774b0b4c45d0de027ba6031 (patch)
tree9571511996a40fa80556cab40239dd99b69bebd1 /dev-perl/Net-RBLClient/Net-RBLClient-0.500.0-r2.ebuild
parentdev-util/electron: Distribute patches in a tarball. (diff)
downloadgentoo-d1614f05077ba25d4774b0b4c45d0de027ba6031.tar.gz
gentoo-d1614f05077ba25d4774b0b4c45d0de027ba6031.tar.bz2
gentoo-d1614f05077ba25d4774b0b4c45d0de027ba6031.zip
dev-perl/Net-RBLClient: EAPI6 + tests
- EAPI6ify - Enable tests - Add basic compile test Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Net-RBLClient/Net-RBLClient-0.500.0-r2.ebuild')
-rw-r--r--dev-perl/Net-RBLClient/Net-RBLClient-0.500.0-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Net-RBLClient/Net-RBLClient-0.500.0-r2.ebuild b/dev-perl/Net-RBLClient/Net-RBLClient-0.500.0-r2.ebuild
new file mode 100644
index 000000000000..e2a1ebaa019d
--- /dev/null
+++ b/dev-perl/Net-RBLClient/Net-RBLClient-0.500.0-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ABLUM
+DIST_VERSION=0.5
+inherit perl-module
+
+DESCRIPTION="Queries multiple Realtime Blackhole Lists in parallel"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="virtual/perl-Time-HiRes
+ dev-perl/Net-DNS"
+
+S=${WORKDIR}/RBLCLient-${DIST_VERSION} # second capitialized 'l' is deliberate
+
+src_test() {
+ local MODULES=(
+ "Net::RBLClient 0.4"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}