summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-12 05:36:06 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-12 08:27:39 +1300
commit7e41cd913f99e26122f327c2800899a2d03cd653 (patch)
tree9e2767a6bc8b9b77c17dd15afbd8aa8d16e29c64 /dev-perl/Net-SSH-Perl/Net-SSH-Perl-2.140.0.ebuild
parentdev-perl/HTTP-Cache-Transparent: Fix missing test dep on Test-RequiresInternet (diff)
downloadgentoo-7e41cd913f99e26122f327c2800899a2d03cd653.tar.gz
gentoo-7e41cd913f99e26122f327c2800899a2d03cd653.tar.bz2
gentoo-7e41cd913f99e26122f327c2800899a2d03cd653.zip
dev-perl/Net-SSH-Perl: Bump to version 2.140.0
- Replace sed expr with patch - Killall authortests Upstream: - Add curve25519-sha256 alias - Fix handling unsupported key types - Add support for '-' in syntax options - Add wildcard support for '+' in syntax options - Fix reading ETM Mac input bytes - Fix DSA verification failure with r/s high-bit - Improve efficiency of CTR - Avoid warnings in Host from strange/invalid known_host entries - Make AES-CBC IV to be blocksize, not keysize - DES3 init now passed key as variable to avoid scalar error - Fix Packet padlen decode using signed instead of unsighed unpack - Fix key not being loaded prior to agent use - Fix DSA verification failure when r has unnecessary leading 0's Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Net-SSH-Perl/Net-SSH-Perl-2.140.0.ebuild')
-rw-r--r--dev-perl/Net-SSH-Perl/Net-SSH-Perl-2.140.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-perl/Net-SSH-Perl/Net-SSH-Perl-2.140.0.ebuild b/dev-perl/Net-SSH-Perl/Net-SSH-Perl-2.140.0.ebuild
new file mode 100644
index 000000000000..ea851df135aa
--- /dev/null
+++ b/dev-perl/Net-SSH-Perl/Net-SSH-Perl-2.140.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SCHWIGON
+DIST_VERSION=2.14
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="Perl client Interface to SSH"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal test"
+
+RDEPEND="
+ >=dev-perl/Crypt-Curve25519-0.50.0
+ dev-perl/Crypt-IDEA
+ >=dev-perl/CryptX-0.32.0
+ virtual/perl-Digest-MD5
+ dev-perl/File-HomeDir
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ >=dev-perl/Math-GMP-1.40.0
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/String-CRC32-1.200.0
+ !minimal? (
+ dev-perl/Digest-BubbleBabble
+ dev-perl/Crypt-RSA
+ dev-perl/TermReadKey
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.610.0 )
+"
+
+PERL_RM_FILES=(
+ # Gentoo integrity checks are used instead
+ 'SIGNATURE'
+ 't/00-signature.t'
+ # Annoying author tests
+ 't/99-perlcritic.t'
+ 't/99-pod.t'
+ 't/99-spellcheck.t'
+ 't/99-yaml.t'
+)
+PATCHES=(
+ "${FILESDIR}/${PN}-2.14-no-signatures.patch"
+)