summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-03-05 11:14:00 +1300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-05 21:32:32 +0100
commit6cc0c3d288184d214f79875398c9e854b1ffd6e6 (patch)
tree90b67630a03963fc54643d0c4e181c0412c15f6c /dev-perl/Net-SSH2/Net-SSH2-0.580.0.ebuild
parentdev-perl/Net-SMTPS: Bump to version 0.40.0 (diff)
downloadgentoo-6cc0c3d288184d214f79875398c9e854b1ffd6e6.tar.gz
gentoo-6cc0c3d288184d214f79875398c9e854b1ffd6e6.tar.bz2
gentoo-6cc0c3d288184d214f79875398c9e854b1ffd6e6.zip
dev-perl/Net-SSH2: Bump to version 0.580.0
- EAPI6 - Better DESCRIPTION - Add examples Upstream: - support auth_publickey_frommemory method - better scp_put and scp_get methods - workaround for bug in libssh2_agent_disconnect Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-perl/Net-SSH2/Net-SSH2-0.580.0.ebuild')
-rw-r--r--dev-perl/Net-SSH2/Net-SSH2-0.580.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/Net-SSH2/Net-SSH2-0.580.0.ebuild b/dev-perl/Net-SSH2/Net-SSH2-0.580.0.ebuild
new file mode 100644
index 000000000000..3130f0311fb7
--- /dev/null
+++ b/dev-perl/Net-SSH2/Net-SSH2-0.580.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=SALVA
+DIST_VERSION=0.58
+inherit perl-module
+
+DESCRIPTION="Support for the SSH 2 protocol via libssh2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gcrypt libressl examples"
+
+RDEPEND="
+ sys-libs/zlib
+ net-libs/libssh2
+ !gcrypt? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ gcrypt? (
+ dev-libs/libgcrypt:0
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-Constant
+ >=virtual/perl-ExtUtils-MakeMaker-6.50
+"
+
+src_configure() {
+ use gcrypt && myconf=gcrypt
+ perl-module_src_configure
+}
+
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins example/*
+ fi
+}