summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-08-23 20:53:45 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-08-23 20:53:45 +0200
commitf8c21c981f41cada1a68e191467eabc50ea4b587 (patch)
tree1e0e825904da52aa2994b4666a9413a402d7871b /dev-perl/Net-SSLeay/Net-SSLeay-1.650.0-r1.ebuild
parentdev-perl/YAML-Tiny: Version bump. (diff)
downloadgentoo-f8c21c981f41cada1a68e191467eabc50ea4b587.tar.gz
gentoo-f8c21c981f41cada1a68e191467eabc50ea4b587.tar.bz2
gentoo-f8c21c981f41cada1a68e191467eabc50ea4b587.zip
dev-perl/Net-SSLeay: fix slot :0 on dev-libs/openssl
Slot 0.9.8 is only for binary compatibility (does not even provide headers) and SSLeay will not compile with only that SLOT installed. Acked-by: Patrice Clement <monsieurp@gentoo.org> Github-PR: https://github.com/gentoo/gentoo/pull/36 Gentoo-Bug: 558502
Diffstat (limited to 'dev-perl/Net-SSLeay/Net-SSLeay-1.650.0-r1.ebuild')
-rw-r--r--dev-perl/Net-SSLeay/Net-SSLeay-1.650.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Net-SSLeay/Net-SSLeay-1.650.0-r1.ebuild b/dev-perl/Net-SSLeay/Net-SSLeay-1.650.0-r1.ebuild
new file mode 100644
index 000000000000..9040075e0fe6
--- /dev/null
+++ b/dev-perl/Net-SSLeay/Net-SSLeay-1.650.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MIKEM
+MODULE_VERSION=1.65
+inherit multilib perl-module
+
+DESCRIPTION="Net::SSLeay module for perl"
+
+LICENSE="openssl"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+# test? ( dev-perl/Test-Exception
+# dev-perl/Test-Warn
+# dev-perl/Test-NoWarnings )"
+
+#SRC_TEST=do
+
+export OPTIMIZE="$CFLAGS"
+export OPENSSL_PREFIX=${EPREFIX}/usr
+
+src_prepare() {
+ sed -i \
+ -e "/\$opts->{optimize} = '-O2 -g';/d" \
+ -e "s,\"\$prefix/lib\",\"\$prefix/$(get_libdir)\"," \
+ inc/Module/Install/PRIVATE/Net/SSLeay.pm || die
+ perl-module_src_prepare
+}